cancel
Showing results for 
Search instead for 
Did you mean: 
Create Post
Level 7

SW SAM agent install error on Red Hat Linux - Error in SSL handshake : Connection reset by peer

I have tried installing manually with the .rpm and by pointing the host to the yum repo and I still have issues getting the error.  To the best of my knowledge the firewall is not standing in the way.  Our Windows hosts are all checking in fine.  The agent is initiating the communications, the poller hostname matches, as well as the port.  The username is correct and so does the password (AFIK, how can I verify it's using the correct credentials?), no proxy is required.

0 Kudos
2 Replies

If the "peer" (the repo) is rejecting your connection with an SSL error, my first guess might be that it requires a newer version of TLS (probably at least 1.2) than your client is using. Just a guess without seeing the logs, though!

0 Kudos

On a whim I tried putting http://<Poller IP>/ and noticed the error string changed to:

Failed: provided uri is invalid: https://[http://<Poller IP>]:...rest of url…/

Could it be because the server we're testing setting up is set to only be http instead of https and the agent automatically assumes https?  If so, is there a way to configure it to only go http (only while testing)?

0 Kudos