cancel
Showing results for 
Search instead for 
Did you mean: 
Create Post
Level 8

SAM 6.9.1 PerfStack not loading nodes

Has anyone else experienced a similar issue?

After upgrading to SAM 6.9.1 attempting to view node entities in PerfStack never returns results. I am not seeing any error messages, just can't get past the loading screen. I do not have this issue with viewing application entities. I can view them fine and perform all analysis.

pastedImage_0.png

The same issue happens if I try loading an existing project. This was not an issue when we were on SAM 6.8.

pastedImage_1.png

Tags (2)
0 Kudos
10 Replies
Level 13

bsnyder27​ and kschmalz​, I got this working after talking with Solarwinds support. My problem may not be entirely the same as yours, though. Can you take a look at your cortex.log* files (probably in C:\ProgramData\SolarWinds\Logs\Cortex) and see if you have errors like the one below?

2019-09-19 14:50:46,212 [589] ERROR SolarWinds.ServiceHost.Internal.ServiceLifetimeTracker - Error restarting crashed service SolarWinds.Cortex.Persistence -  (Cortex).

System.Data.SqlClient.SqlException (0x80131904): The operation failed because an index or statistics with name 'NC_Cortex_Documents_Updated_Deleted' already exists on table 'Cortex_Documents'.

  at SolarWinds.Cortex.Internal.Persistence.Sql.SqlSchemaUpgrader.RunUpgradeEngine(UpgradeEngine upgradeEngine, String upgradeDescription)

  at SolarWinds.Cortex.Internal.Persistence.Sql.SqlSchemaUpgrader.<InternalInitializeAsync>d__8.MoveNext()

If you have the same errors, I'll tell you what worked for me. If not, I'll assume that my installation is weird unique.

I have the same error in the cortex logs, what was your fix?

0 Kudos

Hi msawyer​, here's what I did:

1. Dropped the existing index NC_Cortex_Documents_Updated_Deleted. Do this in Database Manager or a SQL Server query window with this query:

USE [SolarWindsOrion]

GO

DROP INDEX [NC_Cortex_Documents_Updated_Deleted] ON [dbo].[Cortex_Documents]

GO

2. Refreshed the view in Performance Analyzer.

You should see in the Cortex logs that Cortex was able to re-create the index and finish the schema migration process. I restarted the Cortex service, but I don't know if that was strictly necessary.

Hey m-milligan

Incidentally, does your database maintenance run on time, without failures? If there is an index issue, it could mean that the Orion maintenance schedule is not running correctly.

- Jez Marsh

Good question. As far as I know, it does run properly, but I will check again.

0 Kudos
Product Manager
Product Manager

kschmalz  wrote:

Has anyone else experienced a similar issue?

After upgrading to SAM 6.9.1 attempting to view node entities in PerfStack never returns results. I am not seeing any error messages, just can't get past the loading screen. I do not have this issue with viewing application entities. I can view them fine and perform all analysis.

pastedImage_0.png

The same issue happens if I try loading an existing project. This was not an issue when we were on SAM 6.8.

pastedImage_1.png

Have you opened a support ticket? Submit a Ticket | SolarWinds Customer Portal  Is this occurring for the same nodes or across multiple types of nodes?

0 Kudos

Hi serena​,

I don't know if kschmalz​ has opened a suppport ticket for this issue, but I have. My ticket is #00387697.

m-milligan  wrote:

Hi serena ,

I don't know if kschmalz  has opened a suppport ticket for this issue, but I have. My ticket is #00387697.

Thank you! We'll be following your case for trends.

0 Kudos
Level 13

Same issue here, started immediately after upgrading to SAM 6.9. Only affects nodes, any other objects/stats are OK.

We have the same issue with the new Perfstack-style resources on node pages (CPU load, etc.).

0 Kudos
Level 8

Same issue here though we're running SAM 6.9.0

0 Kudos