Showing results for 
Search instead for 
Did you mean: 
Create Post
Level 12

INTERNAL ERROR. Could not Create log file

We are demo'ing Orion. Orion Demo 8.5.1 is up and running. Services are up and running. I'm logged in as an Admin.

When I run the Application Monitor (Demo) Exectutable, after the Install Shield starts up, I get an error message:


"INTERNAL ERROR. Could not Create log file. Setup will now abort" Click "OK" and it exits.


Any clues anyone?

What directory is this log file trying to be created in?


0 Kudos
6 Replies
Level 19

 Do you have C-drive?  It might be trying to write a log to the c-drive, and if you don't have one, it gives you an error.  If that's the problem, the work around is this:



Open a command prompt window and type “subst c: <some valid path>”.  This will trick Windows into thinking you have a C drive.


0 Kudos

Thanks for the reply.

Yes, I do have a C: drive. I believe it's possible that the InstallShield is trying to write to a place where it doesn't have the rights to do so. Hence my question: What log file and where?

 I appreciate the quick reply though...

0 Kudos

If you installed in the default location, it would write the files to the Program Files\SolarWinds\Orion directory.

0 Kudos

Do you mean if I installed Orion in the default location (I never get to instruct the Application Monitor installation where I want to install it - it never gets that far)? The answer is "yes", it is in the default location. I don't believe it is the installation executable itself that is the problem. It has something to do with the interactions of the exectable with my server. Obviously it is trying to create then write to a log for which it doesn't have permssions.  I am a local adminstrator. I checked the security and permissions on the Solar Winds directories and subdirectories...AND the C: drive and the C:Windowns\temp drive. Everything looks as it should - Admin has Full Control. This server is in an area of Active Directory that has no Group Security Policies affecting it. I've rebooted several times. The Event Log writes that the "Solar Winds Application Installation completed successfully", so that is no help.I created an OrionApplicationMonitor subdirectory under  Program Files>SolarWinds>Orion>

and created an empty .txt file called OrionApplicationMonitorLog.txt (just guessing that this was the log file the installer was trying to create and write to) and that didn't work either.


I believe it's a permissions issue, but my brain doesn't know where else to look. I was hoping someone who intimately knew what the App Monitor Installation program was trying to do could help me.

0 Kudos

the install log file goes to the APPDATA directory for the current user (by default this is C:\Documents and Settings\<user>\Application Data\Solarwinds).  Make sure you have access to that directory.

0 Kudos

Thanks for the reply....

I believe we fixed it. We decided to rerun the Orion executable (after first backing up our database). Rerunning that, we choose "repair" and let that run. "Repair" suggested we run a hotfix* so we did that. Then we reran the Application Monitor installation and it worked!

Who knows what went wrong, but at this point we don't care. We had problems installing Orion due to a Group Security Policy. After moving the server into another group Orion finished installing. Most likely, beginning the install under one policy then finishing it under another causes some "confusion" inside the server.


*Our original installation of Orion was Eval 8.5.1. It never suggested a hotfix update.
The "repair" installation of Orion was also Eval 8.5.1. It suggests you run the update.
The update we ran was to update 8.5 to 8.5.1. We ran it anyway.
This whole process seemed odd but the end result is good so, instead of trying to figure it out, we move forward!


0 Kudos