cancel
Showing results for 
Search instead for 
Did you mean: 
Create Post
Level 8

IIS AppInsight - Credentials Test Failed despite being admin

Hey guys,

I'm trying to add a bunch of IIS servers using AppInsight. All the nodes are already polled using WMI, using the same account granted with some administrator access (part of admin group).

When I'm polling the same servers for AppInsight, using the same admin account, I get a credential error. I went to check the poller node logs on this jobs, and my credentials seems to work fine... Where is this error coming from?

2017-07-18 03:58:40,524 [STP SmartThreadPool Thread #6] DEBUG SolarWinds.APM.BlackBox.IIS.Jobs.TestConnectionJob - STARTED>

2017-07-18 03:58:40,524 [STP SmartThreadPool Thread #6] DEBUG SolarWinds.APM.BlackBox.IIS.Jobs.TestConnectionJob - Testing WMI connection to 10.130.X.Y as user: Domain\SVCACCOUNT

2017-07-18 03:58:40,524 [STP SmartThreadPool Thread #6] DEBUG SolarWinds.APM.BlackBox.IIS.Jobs.TestConnectionJob - IIS detection - testing cluster

2017-07-18 03:59:20,712 [STP SmartThreadPool Thread #6] DEBUG SolarWinds.APM.BlackBox.IIS.Jobs.TestConnectionJob - IIS detection - opening registry

2017-07-18 03:59:20,728 [STP SmartThreadPool Thread #6] DEBUG SolarWinds.APM.BlackBox.IIS.Jobs.TestConnectionJob - IIS detection - processing values

2017-07-18 03:59:20,790 [STP SmartThreadPool Thread #6] DEBUG SolarWinds.APM.BlackBox.IIS.Jobs.TestConnectionJob - IIS detection - listing running services

2017-07-18 03:59:21,009 [STP SmartThreadPool Thread #6] DEBUG SolarWinds.APM.BlackBox.IIS.Jobs.TestConnectionJob - IIS v.8.5 has been detected. Windows services: True

2017-07-18 03:59:21,009 [STP SmartThreadPool Thread #6] DEBUG SolarWinds.APM.BlackBox.IIS.Jobs.TestConnectionJob - WMI connection test was successful.

2017-07-18 03:59:21,009 [STP SmartThreadPool Thread #6] DEBUG SolarWinds.APM.BlackBox.IIS.Jobs.Utility.PsCheckIisHelper - Testing PS connection. Agent mode: False

2017-07-18 03:59:21,009 [STP SmartThreadPool Thread #6] DEBUG SolarWinds.APM.BlackBox.IIS.Jobs.Utility.PsCheckIisHelper - user: Domain\SVCACCOUNT

2017-07-18 03:59:21,009 [STP SmartThreadPool Thread #6] DEBUG SolarWinds.APM.BlackBox.IIS.Jobs.Utility.PsCheckIisHelper - WsMan URI: https://10.130.X.Y:5986/wsman

2017-07-18 03:59:27,744 [STP SmartThreadPool Thread #6] INFO  SolarWinds.APM.BlackBox.IIS.Jobs.Utility.PsCheckIisHelper - Connection test ended. Finished in 00:00:03.8546754. Result# 1

2017-07-18 03:59:27,744 [STP SmartThreadPool Thread #6] INFO  SolarWinds.APM.BlackBox.IIS.Jobs.Utility.PsCheckIisHelper - Powershell connection test outcome:

AditionalErrorMessage:

CanWebAdministrationLoad:True

CanWebAdministrationRun:True

ErrorMessages:

HostVersion:1.0.0.0

IisVersionMajor:8

IisVersionMinor:5

IsWebAdministrationInstalled:True

PowerShellOne:False

ProcessorArchitecture:AMD64

PSVersion:4.0

RuntimeEnvironment:v4.0.30319

User - Env:Domain/SVCACCOUNT

User - NTAccount:Domain\SVCACCOUNT

User - whoami:Domain\SVCACCOUNT

User - WindowsIdentity:Domain\SVCACCOUNT

UserIsAdministrator:True

WorkerProcessIs32bit:False

2017-07-18 03:59:27,759 [STP SmartThreadPool Thread #6] DEBUG SolarWinds.APM.BlackBox.IIS.Jobs.TestConnectionJob - Outcome=Available. Result:ErrorMessage:'' IsValidCredential:True, IsServiceRunning:True, IsValidPsUrlWindows:True, IsPowerShellInstalled:True, IsPowerShellWebAdministrationInstalled:True

2017-07-18 03:59:27,759 [STP SmartThreadPool Thread #6] DEBUG SolarWinds.APM.BlackBox.IIS.Jobs.TestConnectionJob - <FINISHED

0 Kudos
1 Reply
Level 9

Were you able to resolve this? I have them same issue.

0 Kudos