Showing results for 
Search instead for 
Did you mean: 
Create Post

Third party updates failing


We’re running a trial of Patch Manager 2019.4.0.125 as we are particularly interested in keeping our standard third-party apps up to date. These include, but aren’t limited to, things like Chrome and Adobe Reader DC, although I have been using Firefox for testing.

Whilst the install and configuration of Patch Manager happened without any major issues, all third-party updates fail. I’ve tested with the current version of both Firefox and Adobe Reader DC, on more than one end client, with the same result.

The Patch Manager Update Configuration Wizard and Synchronization works as expected and I can publish and download third-party packages successfully. If I then use Update Management to push the update to a single client machine, the result is generally either ‘Already installed. install is not needed because the update is either not applicable or already installed’ or ‘Installation failed. (If PowerShell script was applied execution had been prevented due to installation failure. Check 'Execute if update failed' to ignore).’ We are not using PowerShell scripts.

The client PC reports Event 20 in the System log, ‘Installation Failure: Windows failed to install the following update with error 0x80246007: Mozilla Firefox 71.0 (32bit for x86 and x64).’

Firefox 69.0.3 (x64) is currently installed for testing.

I have spent two days trawling through support articles both from Solarwinds and Microsoft, and have tried several fixes, to no avail. I have also tried installing the updates manually on the client PC, which are successful. Also, our WSUS environment seems to be working as expected.

Any help would be appreciated.



0 Kudos
1 Reply
Product Manager
Product Manager

I just discussed this issue with your Account Manager, they are going to reach out and arrange a WebEx to get to the root cause.