cancel
Showing results for 
Search instead for 
Did you mean: 
Create Post
Level 7

REST CRUD fails to load devices with Vendor Product or proper Polling

I am new to SolarWinds and using Perl to bulkload to standalone NCM 7.3 with external DB,Using the following REST URIs

CreatNode=> '/SolarWinds/InformationService/v3/Json/Create/Orion.Nodes',
AddPoller=> '/SolarWinds/InformationService/v3/Json/Create/Orion.Pollers',
CreatCfg=>'/SolarWinds/InformationService/v3/Json/Invoke/Cirrus.Nodes/AddNodeToNCM',
AddCfg => '/SolarWinds/InformationService/v3/Json/Invoke/Cirrus.ConfigArchive/ImportConfig',

to Create an Orion.Node, Orion.Poller, NCM.Node, and Upload a config.

The configuration part work fine.
The Orion.Node is created, but passing the SysObjectID fails to cause the
Vendor, VendorIcon, MachineType to populate (Do these have to be manualy
populated?)  Is there a table that correlates SysObjectID with MachineType - the values of
MachineType that I have seen differ from Vendor Product MIB.  

Creating the Poller with Type=ICMP for the generated NodeID fails to generate polling cycle.  I have devices that show there next update time to be shortly after I added them over a week ago. 

Also, when I mouse over the devices on the GUI Home Page it says "Sorry, the content could not be loaded", instead of showing the pop-up polling statistics and known device information.

Here is an example of the two json data structures I added for creating the Orion.Node and the Orion.Pollers.

Orion.Nodes:{"EngineID":1,"SysObjectID":"1.3.6.1.4.1.9.1.222","Status":1,"IPAddress":"10.0.0.1","DynamicIP":"False","IPAddressGUID":"0100000001-0000-0000-0000-000000000000","Caption":"router.name.come","ObjectSubType":"ICMP","Allow64BitCounters":"False","UnManaged":"False"

,"EntityType":"Orion.Nodes"}

Orion.Pollers:{"PollerType":"Ping Test","NetObjectID":"709","NetObjectType":"N","NetObject":"N:709"}

Any help would be greatly appreciated.






0 Kudos
1 Reply
Level 19

A couple of things:

1. There are some more properties that you need to set to make the website happy: set MachineType and VendorIcon to empty string (""). We have a fix for the product that takes care of setting these default values (as well as some other bookkeeping like the IPAddressGUID property), but it hasn't shipped yet.

2. The "PollerType" property needs to be one of the documented values. In this case, you want "N.Status.ICMP.Native".

Hope that helps.

0 Kudos