cancel
Showing results for 
Search instead for 
Did you mean: 
Create Post
Level 8

Topology Mapper - Issues with different user opening a map

Hi All,

     I have setup a series of maps in topology mapper and seem to be working fine.

Now I would like other administrators to view the maps using their logins. Today in testing with another administrator when they try to open my maps they get the following error:

'Can't access the map file'

Your user account doesn't have the appropriate read/write access permissions

Adjust your account's read/write access permissions as needed or contact your system administrator.

The admin doing trying to open the map has the same rights to the server which Topology mapper runs from (Win2k8r2) as I do.

Or is there some other way admins are sharing maps?

Error1.png

Screen cap of the error returned.

Kind Regards,

Andrew.

13 Replies
Level 7

Hi all,

Can NTM create user account for management?

Thanks all!

0 Kudos
Level 10

This might be an old post/question but just to share my experience; The work around here is to give the user full control folder permission where the map is saved which is usually located in the directory C:\ProgramData\Solarwinds\Network Topology Mapper. Once permission has been modified under the security properties of this directory, the error message above should be resolved.

0 Kudos
Level 7

Just letting everyone know, that Andrew has moved on to another task, the task has been passed to me...

I have uninstalled this version 2.1 and installed 2.2 on another Server.

I;ll let you know if I have any issues with this as well.

cheers

0 Kudos

Exporting the map will resolve your issue.... You will need to inform your other folks about the password and the location of your exported map.

Greetings I have the same issue, and I've tried the export and it still displays that error message seen on the initial posters post. Any ideas on how to share an export map on a shared workstation?

Thanks, Phil

0 Kudos
Level 13

This is also my issue!

0 Kudos
Level 8

Thankyou to everyone who contributed.

I cannot believe that Topology mapper would effectively make it this hard to share information (that is meant to be real time, or near enough). I do not want application security for maps, I want security to be left to myself.

When this product was know as Lan Surveyor, it was great. I am getting quickly feed up with the latest version.

I agree, I let it run a scheduled scan and now I can't open the map it created. Useless...

0 Kudos
Level 8

HI BKyle,

I have saved maps to different drive volumes, making sure folder and files permissions are identical between our accounts.

I make sure I'm logged off on that server as well, just to be sure.

We still get the same error.

The hyper link in the error message titled " How to check and edit access permissions " leads to nowhere. We have to same map password set, but still no go.

Andrew

Hi,

Did you get this resolved?  I am running into the same problem.  We installed NTM on a dedicated server so the team would have access to the application.

Hello,

To share a map with my team, what I usually do is to export it and put a new password. Simply click File -> Export -> Map and enter the new password.

Hope it helps.

Hi,

I opened a case as well on this and that was Solarwinds recommendation.  We have NTM installed on a dedicated VM.  My goal was to have anyone on our comm team to have the ability to go onto this PC and log in and make the changes needed.  Today, all the maps are associated to my login which I didn't want.  I think we will create a separate account just for this that we can use to log into the VM.


Thanks for your help.

Level 15

Where are your maps being saved?  As a test, if you save the to the root of the C: drive, can other users log in and open the file?