cancel
Showing results for 
Search instead for 
Did you mean: 
Create Post
Level 7

there was no endpoint listening at net.tcp://cppunit:17777/orion/core/businesslayer

After the software install and running for few days. We have power fail, after reboot, I cannot access the Orion Web console, erroe message pop up "there was no endpoint listening at net.tcp://cpputil:17777/orion/core/businesslayer". I check with all required service were up and running. (UTIL is the collerctor/server)

16 Replies
Level 20

So is this a new update to a module that's breaking everything?  Two seemed to hint at NCM being part of the problem???

0 Kudos

I had the problem last week.

The problem stemmed from a hard down on the server due to a power supply failure. (No warning; no timely shut down of tasks; HARD DOWN)

Support spent 4 hours trying to fix it with me!!!  The results were good but here is what needed to be done:

1. Delete all Licenses on the server. I was thrilled with that step!

(2. Re-activate the licenses - go to SW site and get your long numbers for each product and put them into a Note Pad document to copy/paste into the license manage.

This step must be moved to number  6  below.)

3. Run the Config Wizard to try to synch up the products.

4. If that does not work, you must get support involved to delete some screwed up DLL's and possibly an application or two.

5. Re-install all products and make sure that they synch up. Error codes don't count here.

6. After the product seems to have done a correct install (as if this was the first time or you would be doing a full upgrade), you will need to synch up License Manager's information by Activating the Products. (This may include Engineer's Tools even though it really shouldn't be involved!)

Allow for the system to bring up all of the programs and the WEBSITE, which can take a long time to fully come up.

Test to see if you can get in.

Important suggestion:  Get support on the line with a "GOTO MEETING" to get them to do the work. This is a known bug but there is a pitiful lack of documentation from DEV on how to correctly fix it. My installation is up and running. Actually, it seems that some stuff got cleared out.

One further note: Please look at the NTA server and check for MEM  Type files and UPDATE type Files under the database folder tree for TEMP files. You may need to process those as well. I'm still working on DEV to help with that.

Mark

Thanks for the update... heads up about these kind of issues are Gold for those of us whose well being hangs in the balance over some of this all working right!  It sounds like it was a nightmare but I'm glad to hear you got it fixed somehow!

0 Kudos

I ran windows update earlier today and got the same error message. Another thread suggested I tried everything suggested here with no success. I found a separate thread that alluded to my NTA installation being corrupt and suggested repairing from the Add / Remove programs. Tried that and got the error message on the link below during the repair process.

Cannot connect to the NTA Flow Storage database hosted on a separate server - SolarWinds Worldwide, ...

Contacted support and the analyst tried a couple of different things that did not work at first

- Ran OrionPermissionChecker and tried to fix the items that needed to be repaired.

- Re-ran the config wizard but got stuck with NTA.

In my case, the windows update installed .NetFramework 4.7 and this seemed to corrupt the website certificate.


Download and run this file

http://downloads.solarwinds.com/solarwinds/Release/PreRelease15/Beta/SolarWinds.FixIt.Md5.1.0.0.7-Be...

Then re-run the configuration wizard again to fix the services.

That's what the tech did to resolve my issue. Hope this helps someone.

GREAT add on info for this sort of thing.

Thanks for the update!!

Mark

Level 12

Folks, re-installing NCM 7.4 Hotfix 1 (which is the archive section) fixes the problem. It re-installs an earlier version of Solarwinds.Cirrus.BusinessLayer.dll

No more crashes!

Don

Did not work for me. I ended up having to reinstall NCM 7.4.

0 Kudos
Level 12

Same problem here.... had several remotes with TAC, but no fix.

SURE WISH SUPPORT WOULD COME OUT HONESTLY ABOUT THIS PROBLEM AND GIVE US AN ETR

Level 12

0 Kudos

What if the offending module is the business layer? I'm getting the error message

"There was no endpoint listening at net.tcp://<hostname>:17777/orion/core/businesslayer" in the Web console.

0 Kudos

My issue is fixed. It looks like the way it was installed ( before I came along ) was incorrect. I got it fixed with help from Tech Support.

Level 12

Anything further on this would love to know why you encountered that problem. I did also but it was as a result of the Solarwinds Orion Module engine service stopping so I restarted and we were good to go. Our db has been acting very strangely recently so I think there is an underlying issue I am not aware of yet.

0 Kudos
Level 8

Did you ever find a solution to this problem? I am running into the same error message while trying to finish Orion Configuration Wizard.

0 Kudos
Level 8

We have had this same issue for a week or two, brand new build, new server, etc.  We have plenty of room, memory, etc.  The only thing I have found so far that fixes it is stopping our Symantec Endpoint Protection.  Once I did that, it ran fine.  I did a Start, Run, SMC -STOP and have been testing it for a few days.  We are running version 12.x of SEP and had added many centralized exceptions, the entire SQL folder, IIS, etc but it still seems to do something so need to figure that out next.  Hope it helps.

Level 9

Hi Raphael, any luck with this issue yet? We are busy migrating to a new server and have transferred everything but now we have the same problem.

Regards,

Louis

0 Kudos

No, It is still outstanding 😞

0 Kudos