Showing results for 
Search instead for 
Did you mean: 
Create Post
Level 7

No NTA data for latest 2020.2 RC3

Hello everyone,

I upgraded NPM and NTA to 2020.2 RC3.  All seems to be working except NTA has no data.  I was able to see netflow data coming from devices to the server Orion is installed using Wireshark.  Is there any suggestion? I opened a support case also but still awaiting on responses.


0 Kudos
8 Replies

Is the NTA service running on your Orion server? I had some issues upgrading from RC2 to RC3 with the service not wanting to actually start & run.

0 Kudos

I have that issue as well, with the NTA service not able to start on 2020.2 RC3 - How did you fix that?

0 Kudos

Yes, SolarWinds NetFlow Service is running.


0 Kudos

any answer hier, is NTA running now?

0 Kudos

Hi all,

Yes, NTA is working now.  

Below were the errors that I had.  I went in every node and deleted all the interfaces, then I re-add them again and NTA started to work again.

ERROR SolarWinds.Netflow.Processing.FlowSource.InterfaceMapping.InterfaceMapper - Failed to update interface mappings. New data will not be visible until the next successful retry.
System.Data.SqlClient.SqlException (0x80131904): The MERGE statement attempted to UPDATE or DELETE the same row more than once. This happens when a target row matches more than one source row. A MERGE statement cannot UPDATE/DELETE the same row of the target table multiple times. Refine the ON clause to ensure a target row matches at most one source row, or use the GROUP BY clause to group the source rows.
at System.Data.SqlClient.SqlConnection.OnError(SqlException exception, Boolean breakConnection, Action`1 wrapCloseInAction)


0 Kudos

I was running in to the same thing.....NTA was running, and said everything was good, but none of my flows were being added to the database.  Same exact error in the logs.

I tried the deleting a node and re-adding it, no luck.

I tried deleting the interfaces on a node and re-adding them, no luck.

Eventually, development wanted me to delete a "NTA virtual interface from NPM".  Having no idea what they meant by that, I searched the NPM interfaces that I had, and found a few virtual interfaces that were created from a Meraki Security Appliance.  As soon as I deleted them, the flows started processing again.


Hopefully this info will help others that run in to this error.  Not sure if it is always a virtual interface, but that was the cause in my case.

0 Kudos

Also, I found this will occur if there are any instances where a node or interface somehow got created twice and is now duplicated.  I had a few nodes that would still not process flows, and it was because the same node was added twice to NPM.  Once you delete the duplicate node the remaining one starts working correctly.

0 Kudos

Is there any way to find duplicate Interfaces easily?

I have found and removed one duplicate Node, removed virtual interfaces and the problem still exists 😞

I am on the 2020.2 final release and have a ticket in with Solarwinds, but I need this fixed ASAP

0 Kudos