Showing results for 
Search instead for 
Did you mean: 
Create Post
Level 7

NTA Website Configuration Failed

I'm currently trying to finish installing the NTA 4.0.1 . I've completed the NTA database install part and I'm now working on the NTA server portion.

At the very end of the install, when the window opens and has ' Configuration installing' with the status bar showing progress, it finishes with an error.

Specifically it says:

*Website Configuration Failed: Un-handled exception occurred during instantiating type [SolarWinds.Orion.Core.Discovery.Plugin] from assembly [SolarWinds.Orion.Core.DiscoveryPlugin]*

Went ahead with the HotFixes but I received the same error during the configuration phase of each HotFix.

Did some research, and the discovery plugin mentioned in the error is from HotFix 2 on the NPM module.

A theory was it needed to be un-installed and re-installed? I shouldn't install it period? It was installed incorrectly?

If anyone has any experience in this, I would greatly appreciate the feedback. Working to get this installed on an Enterprise network now rather than later.



Labels (1)
0 Kudos
5 Replies
Level 8

Sorry to bump this old post, but I just installed 4.1.1 and ran into the same problem.  I ran the configuration wizard again on the Website and resulted in another NCM error.  Did this ever get resolved?

First one:

Website configuration failed:

    •  Unhandled exception occured during instantiating type [SolarWinds.NCM.Discovery.Plugin.NcmDiscoveryPlugin] from assembly [SolarWinds.NCM.Discovery.Plugin]


Website configuration failed:

    •  Exception while configuring plugin SolarWinds® NCM Integration Plugin component Orion Website Update. Request for the permission of type 'System.Security.Permissions.RegistryPermission, mscorlib, Version=, Culture=neutral, PublicKeyToken=b77a5c561934e089' failed.

0 Kudos


NCM guys gave me this help last time:

  • Go to NCM Program Directory
  • Give permissions to these two files:
    SolarWinds.Cirrus.BusinessLayer.dll, SolarWinds.NCM.Discovery.Plugin.dll => Right Click -> Properties -> Un-Block
  • Additionally, Right Click -> Properties -> Security -> Add Group Everyone
  • Re-Run CW (run it as Administrator)


0 Kudos

Thanks for the response Petr.

I opened a ticket but resolved it before support could provide much direction.  Along the way I learned some things that hopefully might be useful to someone.

I am running NPM 11.5.2 with integrated DPA 9.5.0.  I had installed the DPA 10.0.0 without running the configuration wizard after.  I then proceeded to install NTA 4.1.1 and when the configuration wizard did run, it failed with the errors above along with the web site not loading.

I ended up uninstalling the DPA, NTA and repairing NCM.  This resolved the web site not loading.  From there I installed NTA and it worked.  I can provide more specifics if necessary.



0 Kudos

I can recommend to go directly to 4.1.1: NTA 4.1.1 SR Release Candidate available

0 Kudos

My advice here would be to get diagnostics from the poller(s) and log a support case.You could try running the Configuration Manager (not the installer for NTA) again, and repair everything, see if that fixes the problem, but I'd log that support call as a CYA exercise.

If SolarWinds advises that you do the repair and it goes pear shaped, at least you have the 'Support told me to do it' shield

- Jez Marsh
0 Kudos