cancel
Showing results for 
Search instead for 
Did you mean: 
Create Post
Level 8

NTA Issue

I am an issue where I am not seeint Netflow on the NTA dashboard "The Netflow field == Never received" - However, I can see traffic in and out

 Troubleshooting steps:

*Making sure the device is set up fore monotoring in Solarwinds

*Making sure I select the resource list

*In the NTA section, I make sure I select the interfaces where I want to receive Netflow from.

*Using Wireshark and verify that that server is getting Netflow data (I see the Source/Destination IPs and the default field). However, this data not not displaying in NTA. 

9 Replies
Level 11

Check the interface that you are wanting to monitor and verify if you have assigned the appropriate flow control to that interface. I would also check your flow exporter record and monitor to make sure you have the right ip address and port/protocol used. Just as a reference here is a link to use

 

https://www.cisco.com/c/en/us/td/docs/switches/lan/catalyst3750x_3560x/software/release/15-0_1_se/co... 

0 Kudos

The flow is been sent out from the switch and i verify on the Solarwinds server with Wireshark that the Netflow is been received.

 

TEST_SWITCH# sh flow exporter
Flow timeout 10
Flow exporter SW_FLOW_EXPORTER:
Description: Export Netflow
Destination: 10.115.211.110
VRF: default (1)
Destination UDP Port 2055
Source Interface Ethernet1/16 (10.115.100.251)
Export Version 9
Sequence number 145185
Data template timeout 60 seconds
Exporter Statistics
Number of Flow Records Exported 233124
Number of Templates Exported 24231
Number of Export Packets Sent 145186
Number of Export Bytes Sent 18635720
Number of Destination Unreachable Events 0
Number of No Buffer Events 0
Number of Packets Dropped (No Route to Host) 4
Number of Packets Dropped (other) 0
Number of Packets Dropped (LC to RP Error) 0
Number of Packets Dropped (Output Drops) 0
Time statistics were last cleared: Never

Feature Prio: Netflow

0 Kudos
Level 9

On Cisco routers (IOS-XE), Netflow cannot be forwarded out the built in management vrf interface if that is what you are trying to use.

0 Kudos

You should also check on your device and make sure that flow packets are being sent, on a cisco router this might be "show flow exporter statistics".   

Then check and make sure you can ping the Solarwinds server from the interface that flow statistics are being sent out on.   If you aren't specifying the source interface, or the VRF, its usually a good idea to do so.   On a Cisco router you do this in the "flow exporter" section.   If using VRF's you put what VRF you want to communicate with the Solarwinds server on, ie: "destination 1.2.3.4 vrf NetworkManagement" where 1.2.3.4 is the Solarwinds server IP and the VRF name is "NetworkManagement".   Then, you put in the same section a "source Loopback0" and make sure that interface is in the same VRF you mentioned above.    If not using VRF's simply leave that out.

As a last resort, make sure you're getting the packets on the Solarwinds server, you can do this with Wireshark, and can put either a display filter or capture filter for UDP 2055, assuming your using that for Netflow.   Oh, that can be important too.   Make sure you specify the port, its possible your platform defaults to something else like 9995. 

0 Kudos

The flow is sent a received by the server. But the NTA section says never received. this is not working only on Cisco devices - I am getting flow on Palo Alto

TEST_SWITCH# sh flow exporter
Flow timeout 10
Flow exporter SW_FLOW_EXPORTER:
Description: Export Netflow
Destination: 10.115.211.110
VRF: default (1)
Destination UDP Port 2055
Source Interface Ethernet1/16 (10.115.100.251)
Export Version 9
Sequence number 145185
Data template timeout 60 seconds
Exporter Statistics
Number of Flow Records Exported 233124
Number of Templates Exported 24231
Number of Export Packets Sent 145186
Number of Export Bytes Sent 18635720
Number of Destination Unreachable Events 0
Number of No Buffer Events 0
Number of Packets Dropped (No Route to Host) 4
Number of Packets Dropped (other) 0
Number of Packets Dropped (LC to RP Error) 0
Number of Packets Dropped (Output Drops) 0
Time statistics were last cleared: Never

Feature Prio: Netflow

0 Kudos
Level 9

I am having the same issue and did all the same steps. I have not had time to open a support ticket yet.

Were you able to resolve this issue? It looks like we are having a similar problem.

0 Kudos

@morpheusthe fix for us was to install the latest hotfix for 2020.2. (Hotfix 1)

0 Kudos

I have a call set up with support this afternoon. I will let you know.

0 Kudos