cancel
Showing results for 
Search instead for 
Did you mean: 
Create Post
Level 7

primary and backup link stuff

Guys,

Question, is there a way if primary link (green) goes down (to red), node must still reflects as up when backup link kicked in (cellular)?

My scenario was even if the cellular backup kicked in, the node still reflects as down (red).

Thanks guys,

0 Kudos
9 Replies

It will depend on the IP address you are polling. It sounds like you're polling the IP address of the interface of the primary link. You need to poll something that will always be up such as a Loopback interface.

0 Kudos

The IP address of the primary link is different from loopback address. How to configure at solarwinds when the primary link is down and the cellular backup kicked in, the node indicator would still be green?

interface Loopback100

ip address 172.29.7.21 255.255.255.255

end

interface Serial0/1/0

ip address 10.63.205.130 255.255.255.252

ip virtual-reassembly in

encapsulation frame-relay IETF

no fair-queue

frame-relay interface-dlci 135

frame-relay lmi-type ansi

end

pastedImage_1.png

0 Kudos

What IP address are you using to monitor the node? Is it 172.29.7.21?

If yes, how does the cellular backup work? Can you still telnet to the router whilst it's running on the cellular backup?

0 Kudos

Yes its 172.29.7.21. If the cellular backup kicked in, i still can't telnet the router.

0 Kudos

Does the cellular backup not use IP? Sorry I don't know how the cellular backups work.

0 Kudos

Yes the cellular backup does have an IP address its Cellular0/0/0  10.49.180.138. So what can i do with it? Is there a script on SolarWinds to do this?

0 Kudos

Can you telnet to that IP when it's running on the backup? Or even when it's not?

You may have to post up your config as I can't see why the loopback interface becomes unavailable when running on cellular. Someone with cellular backup experience may have a better idea.

0 Kudos

No i can't telnet the using the cellular IP. The node should be green since the cellular backup kicked in. That's my concern I'm trying to figure out.

These is the running-config

Building configuration...

Current configuration : 5277 bytes

!

! No configuration change since last restart

! NVRAM config last updated at 08:16:20 MNL Mon Apr 29 2013 by xxxxxx

! NVRAM config last updated at 08:16:20 MNL Mon Apr 29 2013 by xxxxxx

version 15.1

no service pad

service tcp-keepalives-in

service tcp-keepalives-out

service timestamps debug datetime msec localtime show-timezone

service timestamps log datetime msec localtime show-timezone

service password-encryption

service internal

!

!

boot-start-marker

boot-end-marker

!

!

security passwords min-length 8

logging buffered 4096

enable secret 5 $1$xWbj$ImYEz90DtNidbhOl4r/mX/

!

aaa new-model

!

!

aaa authentication login default group tacacs+ local

aaa authorization config-commands

aaa authorization commands 0 default group tacacs+ local

aaa authorization commands 15 default group tacacs+ local

aaa accounting exec default start-stop group tacacs+

aaa accounting commands 15 default start-stop group tacacs+

!

!

!

!

!

aaa session-id common

!

clock timezone MNL 8 0

!

no ipv6 cef

no ip source-route

no ip gratuitous-arps

ip cef

!

!

!

!

!

no ip bootp server

no ip domain lookup

ip domain name globe.com.ph

ip inspect WAAS flush-timeout 10

!

multilink bundle-name authenticated

!

!

chat-script gsm "" "ATDT*99*1#" TIMEOUT 30 "CONNECT"

crypto pki token default removal timeout 0

!

!

license udi pid CISCO2911/K9 sn FGL15481448

!

!

redundancy

!

!

!

!

controller Cellular 0/0

!

ip ssh time-out 30

ip ssh authentication-retries 2

ip ssh version 2

!

!

!

!

!

!

!

interface Loopback100

ip address 172.29.7.21 255.255.255.255

!

interface Embedded-Service-Engine0/0

no ip address

shutdown

!

interface GigabitEthernet0/0

ip address 10.49.174.1 255.255.255.240

ip helper-address 10.50.236.11

ip helper-address 10.50.237.11

ip nat inside

ip virtual-reassembly in

duplex auto

speed auto

!

interface GigabitEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface GigabitEthernet0/2

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/1/0

ip address 10.63.205.130 255.255.255.252

ip virtual-reassembly in

encapsulation frame-relay IETF

no fair-queue

frame-relay interface-dlci 135

frame-relay lmi-type ansi

!

interface Serial0/1/1

no ip address

shutdown

clock rate 2000000

!

interface FastEthernet0/2/0

no ip address

!

interface FastEthernet0/2/1

no ip address

!

interface FastEthernet0/2/2

no ip address

!

interface FastEthernet0/2/3

no ip address

!

interface Cellular0/0/0

ip address negotiated

ip nat outside

ip virtual-reassembly in

encapsulation ppp

dialer in-band

dialer idle-timeout 0

dialer string gsm

dialer-group 1

async mode interactive

ppp chap hostname none

ppp chap password 7 000A1C0801

!

interface Cellular0/0/1

no ip address

encapsulation ppp

!

interface Vlan1

no ip address

!

router bgp 65004

bgp log-neighbor-changes

network 10.49.174.0

network 10.49.174.0 mask 255.255.255.240

neighbor 10.63.205.129 remote-as 24091

neighbor 10.63.205.129 soft-reconfiguration inbound

neighbor 10.63.205.129 filter-list 1 out

!

ip forward-protocol nd

!

ip as-path access-list 1 permit ^$

no ip http server

no ip http secure-server

!

ip nat inside source list xxx interface Cellular0/0/0 overload

ip route 0.0.0.0 0.0.0.0 Cellular0/0/0 200

ip route 10.198.164.37 255.255.255.255 Cellular0/0/0

ip tacacs source-interface Loopback100

!

ip access-list standard xxx

permit 10.49.174.0 0.0.0.15

!

ip sla 1

icmp-echo 10.198.164.37

frequency 15

ip sla schedule 1 life forever start-time now

logging origin-id string IC-AAC-0298

logging source-interface Loopback100

logging 222.127.8.245

access-list 1 permit any

access-list 99 permit 172.20.251.49

access-list 99 permit 172.20.251.53

access-list 99 permit 10.63.205.129

access-list 99 permit 10.49.145.75

access-list 99 permit 222.127.8.240 0.0.0.15

access-list 99 permit 10.49.174.0 0.0.0.15

access-list 99 permit 10.49.135.0 0.0.0.255

access-list 99 permit 10.198.164.36 0.0.0.3

access-list 99 permit 10.198.164.164 0.0.0.3

dialer-list 1 protocol ip list 1

!

no cdp run

!

!

!

!

snmp-server community solarwind RO

tacacs-server host 222.127.8.244

tacacs-server directed-request

tacacs-server key 7 05001301354D4500171112

!

!

!

control-plane

!

!

privilege exec level 7 traceroute

privilege exec level 7 ping

privilege exec level 7 show interfaces

privilege exec level 1 show

!

line con 0

exec-timeout 5 0

password 7 045A18030C33495A5D005502

logging synchronous

line aux 0

exec-timeout 5 0

password 7 12181612111909107E2621

no exec

line 2

no activation-character

no exec

transport preferred none

transport input all

transport output pad telnet rlogin lapb-ta mop udptn v120 ssh

stopbits 1

line 0/0/0 0/0/1

script dialer gsm

no exec

rxspeed 7200000

txspeed 5760000

line vty 0 4

access-class 99 in

exec-timeout 5 0

password 7 12181612111909107E2621

logging synchronous

transport input telnet ssh

line vty 5 15

access-class 99 in

exec-timeout 5 0

privilege level 15

password 7 12181612111909107E2621

logging synchronous

transport input telnet ssh

!

scheduler allocate 20000 1000

ntp server 222.127.8.242

end

0 Kudos

I'm not sure what the problem is but it looks to me like a configuration issue on your router.

I'm guessing whilst you are running on the cellular link, users at the remote site could still ping their gateway 10.49.147.1 but you pinging it from the other end doesn't work so something on the router is blocking ICMP.

Hopefully someone else can look over your config and offer some advice.

Only thing I could see was this "ip nat inside source list xxx interface Cellular0/0/0 overload". Is it supposed to have xxx as the source list number?

This may help also

3G High-Speed WAN Interface Card Solution Deployment Guide - Basic Configurations  [Cisco High-Speed...

0 Kudos