cancel
Showing results for 
Search instead for 
Did you mean: 
Create Post

Why can’t I remotely connect to my SQL server with an eval

I installed a Main Polling Engine with a bunch of modules as a lab and used the Express version of SQL. It all went in fine and it worked pretty well, but then I wanted more. I needed to add an Additional Polling Engine and an Additional Web Server so that I could make a closer replicant of my production Orion. I had a proper DBA set up the production SQL, but I was on my own for the lab and I could not access my cheapy SQL from anywhere.

I found that SQL normally installs with TCP/IP disabled. I don’t know why Microsoft think that it’s a good idea to disable the most popular protocol in the galaxy, but although it works fine for a one server lab, it does not work for anything more complex.

To make it work properly, just run the SQL Server Configuration Manager, dig down into the Network section and enable TCP/IP. It warns that it requires a service restart but a server bounce worked well and gave me time to brew another mug of tea.

robertcbrowning_0-1601392035756.png

Robert,
A very accidental DBA

Tags (3)
1 Reply
Level 13

Go to properties of TCP Protocol and try to set blank for TCP Dynamic ports and enter any desire unused TCP Port nr below (ex.: 4911):

2020-09-30 14_40_47-Custom VIEWS.pptx - PowerPoint.png

0 Kudos