cancel
Showing results for 
Search instead for 
Did you mean: 
Create Post
Level 21

Website Error When I Click an Event

Jump to solution

I attempted to click on an event that had indicated a service was down (as per the APM) and I received the following error.


What is the cause of this?


System.InvalidOperationException: Unknown net object prefix: "Z"
at SolarWinds.Orion.Web.NetObjectFactory.GetInfoForNetObject(String netObjectId)
at SolarWinds.Orion.Web.UI.OrionView.VerifyNetObject()
at SolarWinds.Orion.Web.UI.OrionView.SelectView()
at SolarWinds.Orion.Web.UI.OrionView.OnPreInit(EventArgs e)
at System.Web.UI.Page.PerformPreInit()
at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
0 Kudos
1 Solution
Product Manager
Product Manager

Hmm, ok I will re-open that defect, can you try this workaround

In address bar change:
NetObject=Z:??? to NetObject=AA:???

View solution in original post

0 Kudos
10 Replies
Level 12

I have experienced the same problem. What I did was to restart all services of NPM just to make sure everything will be refreshed and synch

0 Kudos
Product Manager
Product Manager

This is a known defect, I have added you both to the defect as having the issue as well

0 Kudos
Level 21

Thanks Bshopp, I assume this means there isn't anything I can do about it until it is fixed.... that is other than "don't click on those"?

0 Kudos
Product Manager
Product Manager

I am checking if there is a workaround, but at this point I do not have one until fixed

0 Kudos
Level 12

Hi brandon, does this defect has been addressed in SP3?

0 Kudos
Product Manager
Product Manager

I chatted with the Dev team and it does it appear that this should be addressed with SP3

0 Kudos
Level 21

That seems to yield the expected results.

0 Kudos
Product Manager
Product Manager

OK cool, that works as a workaround, I will get that defect re-opened

0 Kudos
Level 21

I now have SP3 installed and am still experiencing this problem.

0 Kudos
Product Manager
Product Manager

Hmm, ok I will re-open that defect, can you try this workaround

In address bar change:
NetObject=Z:??? to NetObject=AA:???

View solution in original post

0 Kudos