cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Motty99
Level 9

Re: V9 Upgrades - Let's here the stories

Just some info for those who have the problem of everything going unknown...I have setup a script to stop and start the Module Engine service every 12 hours, and Orion kept operating over the weekend with no problem.

0 Kudos
bleearg13
Level 14

Re: V9 Upgrades - Let's here the stories



Now that V9 is out I wanted to start a thread on how upgrades from 8.5.X to 9 have been going?  I'm especially interested in people running multiple pollers.

I'm going to wait a could weeks before I upgrade so the bleeding edge folks can work out any issues. ;-)

 

First off, it's definitely a wise choice to wait a bit before upgrading, especially if you have a somewhat complicated Orion configuration.  Mine is pretty vanilla - one poller, separate SQL server, polling about 5500 elements.  I took part in the beta and could not wait to install v9 because of the Universal Device Poller, which makes setting up custom pollers so much easier (but still needs some improvement). 

My upgrade went pretty well, it took about 1/2 hour to upgrade a 5.5GB database.  I can't say there were any show-stoppers for me, which is unusual because my installation always seems to have some major problem after upgrading.  Found a couple more bugs, but nothing that prevents Orion from doing its job.  That said, wait until the first service pack before upgrading, if not the second.  The only real reason to upgrade is the UnDP and if you're not absolutely itching to get that functionality, the rest of the cosmetic bugs in this first release are not worth the headaches they will likely cause you.

0 Kudos
Motty99
Level 9

Re: V9 Upgrades - Let's here the stories

Found a few more bugs...can't set color scheme...just stays gray...also, when setting up, say, a menu bar...make a change and submit...get a "page cannot be displayed"...go back, click on something else, then try to change the bar again, and it works (or not)...it's all very random...


I'm getting the feeling that things will not be fixed quickly, so does anyone know how to go back to 8.5.1?

0 Kudos
bleearg13
Level 14

Re: V9 Upgrades - Let's here the stories



I'm getting the feeling that things will not be fixed quickly, so does anyone know how to go back to 8.5.1?

 

Just out of curiosity, what gives you this impression?  SW typically comes out with an SP for most opened bugs within a few weeks of a new release.  If you haven't opened a ticket on your issues yet, I would do so as soon as possible so they can investigate why this is occurring to your installation.

It's my understanding that to go back to 8.5.1, you need to restore your database from the last 8.5.1 backup.  If you don't have a backup or your backup is too old for you to not want to lose the newly gathered data, you cannot just rollback.

0 Kudos
Motty99
Level 9

Re: V9 Upgrades - Let's here the stories

Yep, have a case open...


I think I do have a backup from the upgrade...


Ah, the aroma of hair burning in the morning.....Smiley Very Happy

0 Kudos
jeff.stewart
Level 15

Re: V9 Upgrades - Let's here the stories

Hang in there, if I had to guess SP1 will probably be out by the end of the week.  Again that's just a guess.   

0 Kudos
bbusbey
Level 11

Re: V9 Upgrades - Let's here the stories

You will need to restore from a backup to get Orion 8.5.1 working.


We now have Orion 8.5.1sp3 and Netflow 3.0 SP2 working fine.


When Neflow 3.0 came out, we could not use it until the SP2 was released because netflow would fill up the transaction log and crash the database.


After installing Orion 9.0 with Netflow 3.0SP2, we experienced the same issue where the transaction log would fill up and crash the database, so we had to fall back to Orion 8.5.1.


 


0 Kudos
jeff.stewart
Level 15

Re: V9 Upgrades - Let's here the stories



You will need to restore from a backup to get Orion 8.5.1 working.

We now have Orion 8.5.1sp3 and Netflow 3.0 SP2 working fine.

When Neflow 3.0 came out, we could not use it until the SP2 was released because netflow would fill up the transaction log and crash the database.

After installing Orion 9.0 with Netflow 3.0SP2, we experienced the same issue where the transaction log would fill up and crash the database, so we had to fall back to Orion 8.5.1.

 

 

 

 

That's strange.  We had similar trouble with 8.5.1 and Netflow 3.0.  Didn't see any issues with Netflow after the 9.0 upgrade. 

0 Kudos
profzoom1
Level 10

Re: V9 Upgrades - Let's here the stories

After running the Configuration Wizard about 1000 times I am finally fully functional on Ver. 9 and everything worked trouble free over the weekend.


Thanks to support for helping me through the upgrade from hell.


My only guess is if things are not working after the upgrade keep running through the Config Wizard until everything works. Not sure why that helped but that is what ultimately fixed my upgrade. About the 20th time everything started correctly and it was good to go. The alerts are all working and I did not have to re-create them after this was working.

0 Kudos
bleearg13
Level 14

Re: V9 Upgrades - Let's here the stories



After running the Configuration Wizard about 1000 times I am finally fully functional on Ver. 9 and everything worked trouble free over the weekend.

Thanks to support for helping me through the upgrade from hell.

My only guess is if things are not working after the upgrade keep running through the Config Wizard until everything works. Not sure why that helped but that is what ultimately fixed my upgrade. About the 20th time everything started correctly and it was good to go. The alerts are all working and I did not have to re-create them after this was working.

 

One thing I have noticed with the Config Wizard is that it sometimes does not wait for the NPM service to stop.  It's happened for me for several releases.  For some reason, my NPM service takes forever to stop, which can often cause the Config Wizard to time-out and just move on ahead.  I always end up having to start the NPM service manually after running the Config Wizard.

0 Kudos