cancel
Showing results for 
Search instead for 
Did you mean: 
Create Post
Level 12

V9 Upgrades - Let's here the stories

Now that V9 is out I wanted to start a thread on how upgrades from 8.5.X to 9 have been going?  I'm especially interested in people running multiple pollers.

I'm going to wait a could weeks before I upgrade so the bleeding edge folks can work out any issues. 😉

Good luck.

BB

0 Kudos
161 Replies

We have made some changes to how the X-axis values are displayed in an upcoming service pack.  When looking at a Last 30 days chart using our internal build, the X-axis values are: "Jun 2008, 7 Sat, 13 Fri, 19 Thu, 25 Wed, Jul".  This matches what I'm seeing in 8.5, and in System Manager.

0 Kudos
Level 9

Upgraded this morning, no problems.


I think everyone is slowly uncovering bugs that they've found (Here's one of mine: ), but other than that, it's pretty feature rich.


I have started to notice problems with some of my custom poller charts showing "No Data Available for the time period selected" which worries me especially. I'm still investigating, but I'm hoping there hasn't been a loss in some of my historical data.


I do like the poller data trasform tool, to allow me to convert poller data to usable information using math functions. This works great for my temperature pollers that report in tenths of degrees, however the new add-in doesn't allow me to assign it at a rate function (i.e. Farenheit or Celcius) as the direct poller assignment does. Again, a minor inconvenience.


Cheers,


Grant

0 Kudos

Upgraded yesterday evening, went reasonably smooth, we had plenty of hitches along the way but nothing we hadn't dealt with before and none of them were serious.


Without going into too much detail we had issue with shutting down the NPM Service as it kept restarting, the module engine was deleted, the alerting engine was deleted and the NPM service then kept shutting down.


 I know it may sound like a mess but it wasn't that bad apart from the first issue every other issue we had was solved by the configuration wizard.


 I have trawled through all of our custom properties and alerts and everything seems to be in shape. I hope I'm not speaking too soon, but the upgrade went smoothly, suppose only time will tell if everything that seems ok is ok


0 Kudos
Level 10

Ok here is how my upgrade went.


I followed all the default setting for doing the upgrade.


It did install 3.5 .net and then started doing the install and finished  --> no problems yet


After install running of configuration wizard, when opening the Orion System Manager I was gettng an error saying it could not open the server. I re-ran the configuration wizard and checked the database ( nothing had changed with the database location) and then once that was done it opened system manager without a problem.


The only issue that I am having so far is when trying to open "Universal Device Poller" it give me an error --> "an Item with the same key has already been added" click OK and once I do that I get can not contact server closing. Not sure what this is or why I am getting this error. This is a new item in the Orion programs list.


Other then that error that is the only thing that I have seen so far that is not working. Still going through everything as well.

0 Kudos

Denny,


I got the same error why I try to run universal device poller: "an Item with the same key has already been added" then " Cannot contact server. Exiting application"


0 Kudos

 BBusbey, can you open a support ticket and get some diagnostics to us?

 Thanks.

0 Kudos




The only issue that I am having so far is when trying to open "Universal Device Poller" it give me an error --> "an Item with the same key has already been added" click OK and once I do that I get can not contact server closing. Not sure what this is or why I am getting this error. This is a new item in the Orion programs list.

Other then that error that is the only thing that I have seen so far that is not working. Still going through everything as well.

There is a fix for this ....Replace the file in the zip attached-
0 Kudos

That didn't work,


I copied the file is the zip to my Orion folder and tried opening the Universal poller and same thing as before "item with the same key has already been added"


What now?

0 Kudos

prozoom1,

 

Did this work?:

"Go ahead save your Reports and maps folders in C:\Program Files\solarwinds\Orion. Then you will need to uninstall and re-install the application, this should resolve the other Application issue.

Sean Martinez "

Wanted to see if you got it working before I waist a lot of time to re-install.

0 Kudos

Nope didn't work for me,


I have a ticket open and a webex session scheduled for this morning with the development team. I will let you know what the fix was after that if we get it resolved.


0 Kudos

No webex session  today I guess they don't know WTF is going on with ver.9 and I am now full hot since I just now received an email stating that they are confused and no word all day until now.


I have 2 tickets open


49810 dealing with the universal poller error saying "an item with the same key has already been added" and it will not open.


49582 problem with virtual interfaces all defaulting to 10 Mb instead of a gig or more and this is happening on my 6500's firewall service modules, F5's, Bluecoat device, basically anything with a virtual interface it wants to make it 10 Mb and this was never an issue in 8.5.x or anything before.


So far I have to give support an E for effort andd that is about it.


0 Kudos

I just now received an email stating that they are confused
 

When we get a bug reported to development, we try to reproduce it.  That's a part of the Dev team, and sometimes they don't have all the info they need to reproduce.  I think the email was trying to gather more info to work on your bug.

0 Kudos

I looked into getting updates regarding those cases and the technician for 49810 is out sick today and the 49582 issue is test tracked, which means development is still seeking possible causes/resolutions.  We'll see if someone from support can reach out to you today.
0 Kudos

Yeah, nothing new here.


I'm still waiting to hear from SW as to how they are going to fix Orion 9 with netflow 3.


They said they wanted to work the issue but I can't "run" with a version that crashes everyday. 


As of now we can't go back to 8.5.1 untill the database is restored. 


And this is what I got when I requested:


       When is Solarwinds ever going to fix their Database Manager to not require SA rights???!!!


0 Kudos

Ok Sorry, very frustrated but the last upgrade and this one have not gone as smoothe as planned.

0 Kudos

Overall my upgrade went very smoothly.  I'm guessing that is mostly due to the fact that we just moved from SL100 to SLX a month ago and installed everything on a new server.  I'm sure the newness of the install helped a lot.

The only glitch I had was when I launched the install it said I had to upgrade my VoIP monitor because ver. 1.0 was not supported.  I guess I missed the install note that said you had to be on VoIP 2.0 SP2.  Problem is I was on VoIP 2.0 SP1, not ver 1.0.  So I guess the installer identified my VoIP 2.0 SP1 incorrectly as VoIP 1.0.   I fixed the issue by loading VoIP 2.0 SP2.  After that the install ran just fine.

 Thanks

0 Kudos

 I ran into the same thing, still upgrading now, but had me frustrated to no end. Finally a reboot solved it.

 

 

 

Addendum: The install went OK, had a few glitches with VOIP monitor, but after I figured out that part, the rest of the install went smooth, no crashes, no unusual abnormalities, and I noticed the web front speed has improved, still no where near the speed of version 7, but much better than version 8.0. The addition of Node management to the web is a huge leap forward for Orion, something that has been sorely needed, and it works! All it needs now is Alert management from the web and it would be perfect.

0 Kudos

My upgrade also went through without any major issues.  We have noticed that the X-axis on the graphs seems to have a mind of its own but that is very well documented in another thread. 


 The upgrade took about 30 minutes on a SL2000 Poller with about 2700 total elements.  We upgraded from 8.5.1 SP3 and this same poller has been upgraded several times over the years so it isn't really what I would call a fresh server.  We are also running the APM 1.0 SP2 and this did not need to be reinstalled and functions normally after the upgrade.


 The universal poller is extremly useful and has saved me at least 2 hours worth of management time for one of our devices.


 Thanks,

0 Kudos

 You should open a support ticket.

https://forms.netsuite.com/app/site/crm/externalcasepage.nl?compid=638609&formid=12&h=3d0552f20b2e9bd6580b

0 Kudos

I had a small DB permissions error because the defaults were not removed in the reg.  Other than that the upgrade was smooth 🙂

 

Thanks SW Orion Team. 

0 Kudos

The upgrade from 8.5.1 went smoothly. I have only begun to put v9 through the paces, but so far, no issues.


The product looks great and I think the consolidation of features is very nice and intuitive.


Good job.

0 Kudos