Showing results for 
Search instead for 
Did you mean: 
Create Post
Level 12

Upgrades Gone Wrong

So I'm on day three of what was suposed to be a simple upgrade. I'm taking NPM 12.1 to 12.2 and SAM 6.4 to 6.6 while removing some products where the license has expired or we aren't finding useful at this time. Additionally, I was looking to eval WPM so I added it to the install list. The first problem I ran into was the installer stuck at "Importing Sample Maps". Initially I removed IPAM and tried again with no luck. Then I removed NCM, VNQM, and UDT. This got me past that point but, there were issues with the web site setup. I ended up blowing away the website completely and allowing the Configuration Wizard to rebuild it. That seemed to work. At this point I had a working primary/core. My envinorment has the Primary, 2-2APEs, and one remote APE. I took the provided installer from the Primary and placed them on the APEs. Initally, they complained that my APE licenses, active and due to expire in 3/2019 according to my Customer Portal, where not active. I made multiple failed attempts through the Primary to sync licenses via the portal provided License Manager. Following a link about reseting licenses, I ended up downoading/installing a standalone license manager tool to the APE. This didn't work either. I tried the same on the Primary which also didn't work. Support tells me that this corrupted me so I guess don't do that!. Support walked me through the deactivation of all my product licenses. I'm told this was neccessary because the sync would not work with the EVAL status that WPM was in. For purposes of getting through this I decided to uninstall WPM. Still, none of my licensed product would reactivate. Support got some license expert on thier end who did some license reseting on thier end and using the portal provided License Manager, I was able to reactivate NPM and SAM but, had to manually add the APEs. There was no sign of WPM so I figured we were good. By my way of thinking we have a working Primary with NPM and SAM. I went to each of the APES and placed the provided installer on them. When running the installer it would fail at a point where it was trying to download a file "UpgradeFix.exe" from the main server. Looking at the installer log file, this was a file supposedly at From each of the APEs, I had no issues using IE to go to that wesite and downloading the file. So I have to assume the its actually trying to get the file from the Primary but, that file does not exist anywhere on it, nor could I figure our where I could put the file where the APE upgrade installer would find it. Support tells me that this file is related to WPM and there must still be remanents of WPM on my Primary. So they send me a "Burn" script. Basically this script wipes the server of any and all Solarwinds products completely. So I run this on the working Primary. After a considerable amount of time it completes. You are admentaly warned not to interrupt the process. I reboot after the burn and reinstall selecting only NPM and SAM, fight through some website configuration issues ending up with a working Primary except for the annoying IE security prompt when opening the UI, which I still have but, will resolve later...I hope. So again, back to the APEs, using the SW portal on an APE, I navigate to the Polling Engines setting and download an installer. When I run it, it pases all the checks but, there it is again, WPM. The installer intends to place WPM on the APE even though there is no WPM. I can't get rid of this thing. I have combed through the Primary removing any and all mentions of WPM from the registry. I have no idea where else to look or what else to do. I've listed this as a question in hopes maybe someone else has had a similar issue and was able to resovle it. Support will get back to me around 1pm my time today after reviewing all the diagnotic information I have provided but, I thought I reach out here to see if I could find some more ideas.

2018-05-22 18:36:16,879 [17] DEBUG (null) SolarWinds.Administration.SystemInfoCollector.Detectors.InstalledProductsDetector.InstalledModulesDetector - Modules detected in msi library: ACTIVEDIAGNOSTICS:, COLLECTOR:, CORE:2017.3.5320.1819, CORTEX:, DPAIM:, DPI:, HA:2017.3.1.851, JOBENGINE:, MIBS:, NETPATH:, NETWORKATLAS:, NPM:12.2.5300.1871, ORIONHA:2017.3.1.3303, ORIONIMPROVEMENT:, RABBITMQ:, RECOMMENDATIONS:, SAM:, SQLCE35:3.5.8080.0, SQLNATIVECLIENT2008:10.0.1600.22, SQLSMO2012:11.0.2100.60, SWA:, SWIS:2017.3.0.710, VIM:, WINPCAPSILENT:, WPM:

This is from the AdminstrativeService log on the Primary, which I beleive the APE installer is using to understand what it shold put on the APE.

25 Replies

Glad to hear the issue was resolved.

Not resolved. That support article was helpful but everything matches up perfectly across all engines.

The last piece of advice I got was to upgrade all pollers (Primary/APEs) to .Net 4.7.2 but, I did not have to do that.

Are you getting the same error as above?

0 Kudos