cancel
Showing results for 
Search instead for 
Did you mean: 
Create Post
Highlighted
Level 14

Unable to list resources on Nexus

Jump to solution

Since upgrading to 2019.4 I've been unable to "list resources" on NX-OS platforms. Has anyone else seen this behavior? Do you have a fix, or shoul dI open a support ticket?


D

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Level 14

Re: Unable to list resources on Nexus

Jump to solution

After contacting support, this was the issue/fix:

  • There's missing file " SolarWinds.Orion.DeviceContext.Strings.dll" on the Inetpub folders
  • Have the services stopped and copied the files that are missing from the installation path to Inetpub
  • Have the services restarted and test the node.

View solution in original post

0 Kudos
4 Replies
Highlighted
Level 14

Re: Unable to list resources on Nexus

Jump to solution

All,

Just adding to this, I also have a ticket opened with support.

  1. List Resources just hangs, even the last cached list doesn't display
  2. I also noted that I was unable to add widgets/resources to views anymore
  3. I ran Configuration Wizard which corrected the issue (yesterday)
  4. The issue has returned today and doesn't appear to be a browser cache issue (fails on both Chrome and Firefox)

Version 2019.4 HF4 - something appears to be corrupting the cache in the system somewhere.

0 Kudos
Highlighted
Level 14

Re: Unable to list resources on Nexus

Jump to solution

After contacting support, this was the issue/fix:

  • There's missing file " SolarWinds.Orion.DeviceContext.Strings.dll" on the Inetpub folders
  • Have the services stopped and copied the files that are missing from the installation path to Inetpub
  • Have the services restarted and test the node.

View solution in original post

0 Kudos
Highlighted
Level 9

Re: Unable to list resources on Nexus

Jump to solution

Got the exact process from a case I opened, see the following reply...

0 Kudos
Highlighted
Level 9

Re: Unable to list resources on Nexus

Jump to solution

Opened a case, got the details of the process and the following is the fix:

1. Stop all Orion Services at all Orion servers.
2. Copy the files on the path below:

    Root Folder C:\Program Files (x86)\SolarWinds\Orion\VDC
    SolarWinds.Orion.DeviceContext.Strings.dll 8.1.0.135

    Root Folder C:\Program Files (x86)\SolarWinds\Orion\VDC\de
    SolarWinds.Orion.DeviceContext.Strings.resources.dll 8.1.0.135

    Root Folder C:\Program Files (x86)\SolarWinds\Orion\VDC\ja
    SolarWinds.Orion.DeviceContext.Strings.resources.dll 8.1.0.135
     
3. Paste the files to Inetpub/Solarwinds folder:

    Root Folder C:\InetPub\SolarWinds\bin\
    SolarWinds.Orion.DeviceContext.Strings.dll 8.1.0.135

    Root Folder C:\InetPub\SolarWinds\bin\de
    SolarWinds.Orion.DeviceContext.Strings.resources.dll 8.1.0.135

    Root Folder C:\InetPub\SolarWinds\bin\ja
    SolarWinds.Orion.DeviceContext.Strings.resources.dll 8.1.0.135
    SolarWinds.Orion.DeviceContext.Strings.resources.dll 8.1.0.135

4. Open command prompt (Run as Admin) then perform IISreset
5. Start all the Solarwinds services.


Worked for me!

0 Kudos