cancel
Showing results for 
Search instead for 
Did you mean: 
Create Post
Level 9

Trap Viewer and Syslog Viewer Stopped Working

At one of our sites we recently started receiving an error when trying to launch Trap Viewer or Syslog Viewer. Any time one of the applications is launced, the following error is received.

Trap_Viewer_Stopped_Working.PNG

The same general error appears for Syslog Viewer as well, except is says "Syslog Viewer has stopped working". We have checked our other sites and this seems to be the only one having this issue.

This instance is on a Windows Server 2012 R2 server. Current Orion Platform is 2017.3.5 SP5, NPM 12.2. The other instances that ARE working are on the same platform and product versions as well, with the same level of of Windows patches applied.

We have already tried rebooting the server and running a repair of Orion Core Services, neither of which helped. We have an open support ticket on this, but thought I'd reach out to the community to see if anyone has experienced this before or has any recommendations. Any help would be appreciated! Thanks.

Labels (1)
0 Kudos
20 Replies
Level 9

I have the same issue! This is beyond frustrating, as we cant even utilize trap or syslog functionality. Multiple support tickets were opened, still no fix. Here is the weird thing...it works fine on my Main poller HA server!  

0 Kudos

Yeah, unfortunately we don't have a HA server to try it on, but it works at other sites, this is the only one so far that we've found the problem on. They passed it to the Dev team over a month ago and we haven't received any word on it since then. It might be time for me to hit them back up as this kind of fell of our radar. Thanks for reminding me! If we get a resolution I'll get it posted here.

0 Kudos

I am not sure if its true or not, but i was reading on thwack that trapviewer and syslog viewer got deprecated  - What will happend with trap/syslog viewer ?

0 Kudos

That is correct but that wasn't the case when this thread was first created back in June 2018.

0 Kudos

even if the syslog viewer and trapviewer got deprecated, we should still be able launch the application right ? you think not having older version of .net framework(3.5 and 4.0) would cause this issue ?

0 Kudos

When I launch the old application I get the following message

pastedImage_0.png

But once I click Ok the application will launch. I'm running 2019.4.

0 Kudos

By any chance you have .netframe work enabled 3.5/4.0 on the window server ? it seems that our legacy report writer, syslog viewer, and trap viewer doesnt work( not new).

0 Kudos

Sorry for the late reply, but yes we have 3.4 & 4 on the server.

0 Kudos

did anyone get this fixed. lol having same issues as well

0 Kudos

Sorry elien​, a week after my last post in September of last year I left that customer site and have not had access to their environment since, so I'm unsure if they're still having the same issue or not. Honestly, after over a year I hope they've updated to a more current version and resolved the issue, or implemented LA as Log Analyzer is pretty sweet.

If you're able to upgrade to the new 2019.4 platform, you can actually use the new log viewer framework and save the heartache of using the legacy applications, however you won't be able to import the rules you had created unless you pay for the Log Analyzer module from my understanding.

Sorry I'm not really able to help out on this one any further. Hopefully somebody else will be able to chime in with some sort of update. Best of luck!

0 Kudos
Level 9

Just figured I'd post an update on this thread. This actually still has not been resolved. We've had a ticket open and SW support has passed this one along to their Dev team. We're just waiting to hear what Dev has to say about it.

This apparently effects the Report Writer Application too. If I open Report Writer and select the type of report to make, once I select the type, the application crashes with the same type of error. I'm interested to see what the Dev team has to say about this.

0 Kudos

I recently encountered a similar issue that had to do with licensing.  I installed an APE but forgot to license it.  It came up running fully--except for Trap & Syslog functionality.  I talked with Support and they noted it wasn't licensed.  A quick deployment of an available NAM license and I was back in business in seconds.

How's your license?

What is a NAM license?

I only have APE licenses and the syslog and snmp services are not installed on the APEs

To me this looks to be deprecated on APEs in 2019.4, which to us is bad, we have our APEs used as syslog and trap receivers as part of a VIP

0 Kudos

rschroeder​ It looks like the licensing is OK on the server. While looking at the licensing, however, we did notice that the additional polling engine is on a different hotfix level. I doubt this would cause Trap Viewer and Syslog Viewer not to open on our primary poller, but we are going to patch that up first. I'll be sure to post here after that is completed in the next couple of days (hopefully) and let you know if that resolved any problems. Thank you!

Level 16

0 Kudos

neomatrix1217​, thanks for the suggestion, however it did not resolve the issue. We changed the DEP to only essential progarms and services and rebooted the server. We are still getting the same error now.

I forgot to mention in the first post, it seems like every time the application gives the error we get an 2 errors in the Event Viewer related to it. We get "Application Error" with Event ID 1000. We also get a ".NET Runtime" Error message with Event ID 1026. This makes me lean toward thinking it's an issue with .NET Framework.

0 Kudos

Was the system (SolarWinds Server) patched recently - I mean just before this issue appeared OR was any change performed on the server ? From your comments i do understand the issue started all of sudden and these executable s were running fine till date.

vinay.by​ The server was upgraded to the latest version of Orion modules back in March. I have only been at this customer site for a couple of weeks, and unfortunately nobody can confirm whether or not is was working on this server since that upgrade was completed. I was working under the assumption that they knew it was working after the upgrade, but that may not be the case.

0 Kudos

Also, you can tell the customer that we have a nice new Log Manager that is going to be released soon and he won't need to use that application anymore.

https://www.solarwinds.com/-/media/solarwinds/swdcv2/licensed-products/log-manager/resources/datashe...

Log Manager for Orion

Built on the Orion Platform, Log Manager integrates directly with Network Performance Monitor, Server & Application Monitor, or any of the other Orion Platform-based products for side-by-side performance and log monitoring.

  • See log data in real-time with an interactive live stream
  • Rapidly identify performance and availability issues through log data
  • Search, filter, and tag logs to accelerate search and analysis
0 Kudos

If turning off DEP doesn't work (and I DO like that idea!), then:

  • Run the Diagnostics Wizard.
  • While it's generating diagnostics, open an online support case with Solarwinds.  Set its priority System Down.
  • Once the case is created, upload the Diagnostics to its Ticket Number.
  • Then call Solarwinds and reference the ticket you created online.

Alternately, you might try re-running the Configuration Wizard on the problem poller to see if it fixes the issue.

Let us know what caused, and what fixes, the issue!

Swift packets,

Rick Schroeder

0 Kudos