cancel
Showing results for 
Search instead for 
Did you mean: 
Create Post
Level 12

Server xxx - Virtual Machine hosted by ESX host xxx

I have a server in my estate that is showing through polling as being a VM hosted on an ESX host, yet when checking the host, it doesn't show there. I kind of expect this as this is a physical server but I'm curious why Solarwinds is determining this to be virtual??

I've checked SNMP settings, polling settings, re-added the node & yet it's still reporting that it is hosted on the (incorrect?) ESX host...

Thoughts welcomed, if more info is needed, let me know

Thanks in advance all you Thwackers out there

0 Kudos
2 Replies
Level 13

I have the same situation.  Any luck on how to fix this?

Update:  After poking around, I found in the VIM_VirtualMachines table where nodeid = 215 (node being reported as virtual, but really isn't) an entry for another server (name = Helper).  When I ping HELPER it has a slightly different IP#.  This virtual server is currently powered off.  I tried to rediscover the ESX Host (nodeid 274) but it didn't change.  So, I edited the table and changed the nodeid from 215 to NULL (like the other ones that weren't running GuestState=notRunning).

Now, when I look at the server on the ESX Host Details, it's greyed out (as expected) and the NodeId 215 shows as a physical server.  Not the best solution, but so far, so good.  (I hope I didn't break something else.)

0 Kudos

Any possibility of name or IP conflict here that could be causing confusion? Multiple network adapters/IPs or the like?

If you remove the problem server node, re-add/rediscover the ESX host, does the machine in question show up on a VMware-native poll/discovery?

0 Kudos