Showing results for 
Search instead for 
Did you mean: 
Create Post
Level 7

Physically device is UP, in Solarwinds its showing Down

Hello Everyone,

I am new to Solarwinds facing this issue need your support in this, I have few nodes which are shown as down. But when I try to ping them from my machine, they are pingable checked with Notwork Administrator they informed device is Up. 

0 Kudos
6 Replies
Level 7

I have deleted the existing node and tried to add once , but i'm getting SNMP error, could anyone help me on this how can I sort it out this issue.

0 Kudos

So either something, like a firewall, is blocking the connection OR you have the snmp community wrong.

You likely have an snmp GUI tool on your orion server at:

C:\Program Files (x86)\SolarWinds\Orion\SnmpWalk.exe

You can use that for testing.  It won't help you tell the difference between a firewall block or a wrong community, but it takes the Orion processes out of the picture, since it's a stand alone utility.

0 Kudos

Future note:

Once you get the node added and working.  When you do a list resources, you have the option of using ICMP or SNMP for the up/down status.  

I cannot say which is better.  Networking people will always chose ICMP, but as the monitoring guy, I prefer SNMP.

The advantage of ICMP is that the device will show green even if something is wrong with snmp.

The advantage if SNMP is that the device will show red, so that you know something is wrong with snmp.

It's just a matter of perspective.  If you want the best of both worlds, then you can choose ICMP, and add another monitor for SNMP, such as using SAM or maybe UnDP.

0 Kudos

If your Solarwinds NPM server can ping the devices, but it still says they are down, you simply need to Edit the device(s) in NPM and confirm it's using the correct polling methods (ICMP?  SNMP-v3?  Agents?), and that everything matches between the node(s) and your poller.

For example, if there were an access-control list or Windows firewall active on the device, but it's not been configured to allow your Solarwinds system to talk to it using the right protocols and pre-shared keys or community strings, you may be able to ping it but it will still show down in NPM, depending on what you've set NPM to use to monitor it.

If there are no ACL's in place that would limit access (if you have to white list your NPM nodes, do so), and if there are no firewalls between the node and your NPM poller, you should be good for monitoring it.

Share some screen shots of how you've set up NPM to Edit a specific problem node.  I bet we can find the issue and make some helpful suggestions. 

  1. Click on the node in NPM
  2. Click on Edit
  3. Review your Polling Method.  Confirm you have the right snmp-v3 credentials (I recommend snmp-v3 for everything, along with SHA1 and AES 256).  If the passwords aren't right, NPM won't be able to monitor.  You can temporarily try using ICMP just to confirm NPM reports the device is up that way, then move back to snmp and review your community strings for a good match.  In my environment I don't allow Write access via snmp--only Read access.  It's a security thing, and might not be best for your environment's needs.  Remember you can deploy Agents onto servers, or us WMI and ICMP for servers, as well as using the API for monitoring Meraki devices.
  4. Leave the polling intervals at default, at least for starters.
  5. The Node Category usually can be left at Auto-detected, but you may find it helpful to customize a template and use that for monitoring specific devices.  For example, I have customized the Cisco ASA template to better monitor/manage configs for our systems.
  6. It can be very helpful to design / plan Custom Properties to help you manage devices by groups that are unique to your environment.
  7. The last item at the bottom is the CLI Device Template--again, Auto Determine is usually the go-to option here, although it's where I select other templates I've customized.
Level 7

Do you have access to log into your solarwinds server?  if so, try pinging from there.  If you can't ping it then validate routing between the server and end point.

0 Kudos

Yes, I am able to ping the devices also tried Tracert.

0 Kudos