cancel
Showing results for 
Search instead for 
Did you mean: 
Create Post
Level 13

Orion NPM 9.5.1

Orion NPM 9.5.1 appeared in our customer portal last night. Since we have been testing the RC for a few weeks, I had enough confidence to put it into production today (multiple pollers, additional web server and hot-standby).

The great news for us is that the syslog and events web pages have had massive performance improvements.

We can now effectively use the syslog webpage - page load time has gone from 25+ seconds to <2 seconds (like a late Christmas present!).

Thanks to the developers!

Just a note for users however - you do need a modern browser to get the full gains. Our testing shows that IE6 just doesn't cut it anymore for adequate performance in Orion.

Dave.

0 Kudos
23 Replies
Level 12

I too have tested this in RC and put it in production with no issue.

Events webpage is finally fast again.  Traps are still slow for me though.

0 Kudos

upgrade just completed, and even during the baseline, the events and syslog is fatser, a lot faster...

i am also hoping that this stops the jobengine crashing....  will monitor....

well done solarwinds....   releasing for performance and bug fixes is brilliant...  with so many features of late, i was really looking forward to some performance increaqses and we got them...

i am sure you have more to come down the line...  for me, i am hoping the website performance is going to get better and better...

cheers

dan

0 Kudos

and i have just noticed that TRAPS page is still slow also...  why is that?  whatever you did to alerts and syslog, can you do it to traps?

0 Kudos

I don't see it in my customer portal. Is there a delay or something?

0 Kudos

I also upgraded to 9.5.1 yesterday, but found when I came in this morning that NCM was VERY unhappy, unable to download configs, etc....

Did some testing, and while trying to download a config from a single device, I received the notorius WEONLYDO! popup screen.

Using the following post I was able to re-register the dlls, and all appears to be functioning properly again.

I did NOT do any additional steps for NCM after loading the NPM 9.5.1 update.

The only issue I ran into when I did the install yesterday was one I have encountered before on the last upgrade while running the install program:

Unable to execute the required file: The following system error has occurred: the system cannot find the path specified. (3)

Found the fix for that at:

http://support.solarwinds.com/kbase/ProblemDetail.cfm?ID=1232

Are these self-inflicted difficulities I am experiencing because I am doing something wrong?

P.S.  I LOVE Thwack - it is nice to get answers without having to open tickets!

0 Kudos

I also upgraded to 9.5.1 yesterday, but found when I came in this morning that NCM was VERY unhappy, unable to download configs, etc....

What version of NCM did you have installed?   We haven't heard this before, but we'd like to look into it.

0 Kudos

NCM 5.5.1

0 Kudos

9.5.1 upgrade went well on two different deployments without any problems.  Syslog page is much faster than in pervious versions.

Thanks.

0 Kudos

9.5.1 upgrade went well on two different deployments without any problems.  Syslog page is much faster than in pervious versions.

Thanks.

0 Kudos
Level 9

Very nice.  I will have to look into upgrading our system.  The syslog portion is starting to become used much more than we anticipated when we implemented Orion.

 

Any word on allowing multiple nodes to have the same IP?

 

Thanks for all your work.

0 Kudos

As far as I know, 9.5.1. contains bug fixes and some performance enhancements only.

Dave.

0 Kudos

Jason, Dave is correct.  9.5.1 was more focused on bug fixes and performance, not so much product enhancements

0 Kudos

Is there any practical reason to update 9.5.1RC2 to 9.5.1? We are quite pleased with the RC2 (thanks for that!) at the moment.

Btw, there is no announce in the announcements forum yet.

Markku

0 Kudos

No, RC2 is what is not GA, so no need to upgrade.

Announcement on forum will be coming shortly

0 Kudos

When I upgraded to 9.5.1 this morning I lost my node properties through the web.



When I edit a node under Node Management I see the node name, IP, SNMP info and Polling but no Node Properties. I verified this against a 9.5 SP4 server that I had not upgraded and it still had properties.



I then ran the Config Wizard (which did not prompt for after I upgraded to 9.5.1 - it just asked to reboot the server).



Once I reran the Config Wizard everything worked as expected.

0 Kudos

Scott, once you did the reboot did the configuration wizard start automatically or did you have to start it?

If during installation is locked a file (e.g. a service) so the Windows Installer set up a reboot and the ConfigWizard is not started. After reboot there should be ConfigWizard started  automatically.

If this did not occur, can you please open a ticket, reference this thread with diagnostics included please. 

0 Kudos

No, it did not prompt or start the CW after the reboot. Once I kicked it off then it sensed that it needed to be run for the NPM. My upgrade on my second server went smoother than my first (same thing with the CW though). On my first server I have had to run the CW 3 times so far. The last time I did it for all pieces. I am keeping my fingers crossed.... and my toes.

Will open a ticket.

0 Kudos

FYI, 9.5.1 is now generally available.   See this announcement for more details.

0 Kudos

Is it possible to run this upgrade without losing all of my customizations, or am I the only one that has added company logos and such to the Orion screens?

I've made changes to a few of the views (login screen, node details. etc.) that always seem to be reset back to default every time I install a service pack. Now that my system is live, I can't afford to lose those changes - again.

Keep in mind all of the changes I have made are cosmetic to make the product just a little more personalized for our environment.

-Ken

0 Kudos

Is it possible to run this upgrade without losing all of my customizations, or am I the only one that has added company logos and such to the Orion screens?

I've made changes to a few of the views (login screen, node details. etc.) that always seem to be reset back to default every time I install a service pack. Now that my system is live, I can't afford to lose those changes - again.

Keep in mind all of the changes I have made are cosmetic to make the product just a little more personalized for our environment.

-Ken

Ken,

Those settings will be overwritten every time the configuration wizard is run against the website.  I have a change I have to make as well.  Just be aware of this as support sometimes has you do this when troubleshooting an issue.

0 Kudos