cancel
Showing results for 
Search instead for 
Did you mean: 
Create Post
Level 9

Nodes with Problems Issue

Dear All,

I am getting below issue. I'm assuming this is related to one or more specific nodes.

Does anyone have an idea how to identify which node(s) it concerns (Query, Log file, ...) ? 

 

johncranen_0-1588596210596.png

Part of the Saver error locally output:

Error Instance: fe45304c42af40a3968dbd6c7c847d95
User: cwwpvt\09280934
URL: https://Orionserver:443/orion/rendercontrol.aspx
Referrer: https://OrionServer:443/orion/rendercontrol.aspx
Message: Specified cast is not valid.
ErrorSite: App_Web.orion_netperfmon_resources_summary_problemnodes_ascx.__DataBinding__control10
ErrorType: System.InvalidCastException
Stack:
at ASP.orion_netperfmon_resources_summary_problemnodes_ascx.__DataBinding__control10(Object sender, EventArgs e)
at System.Web.UI.Control.OnDataBinding(EventArgs e)
at System.Web.UI.Control.DataBind(Boolean raiseOnDataBinding)
at System.Web.UI.Control.DataBind()
at System.Web.UI.Control.DataBindChildren()
at System.Web.UI.Control.DataBind(Boolean raiseOnDataBinding)
at System.Web.UI.Control.DataBind()
at System.Web.UI.Control.DataBindChildren()
at System.Web.UI.Control.DataBind(Boolean raiseOnDataBinding)
at System.Web.UI.Control.DataBind()
at System.Web.UI.WebControls.Repeater.CreateItem(Int32 itemIndex, ListItemType itemType, Boolean dataBind, Object dataItem)
at System.Web.UI.WebControls.Repeater.AddDataItemsIntoItemsArray(IEnumerable dataSource, Boolean useDataSource)
at System.Web.UI.WebControls.Repeater.PostGetDataAction(IEnumerable dataSource)
at System.Web.UI.WebControls.Repeater.CreateControlHierarchy(Boolean useDataSource)
at System.Web.UI.WebControls.Repeater.OnDataBinding(EventArgs e)
at System.Web.UI.WebControls.Repeater.DataBind()
at Orion_NetPerfMon_Resources_Summary_ProblemNodes.Page_Load(Object sender, EventArgs e)
at System.Web.Util.CalliEventHandlerDelegateProxy.Callback(Object sender, EventArgs e)
at System.Web.UI.Control.OnLoad(EventArgs e)
at SolarWinds.Orion.Web.UI.BaseResourceControl.OnLoad(EventArgs e)

Thanks much,

 

John

0 Kudos
2 Replies
Level 16

Take a look at this KB article and see if it corrects the issue.

https://support.solarwinds.com/SuccessCenter/s/article/Clear-Information-Service-Subscriptions

0 Kudos

Thanks for the suggestion, but that didn't help. I did it the hard way by filtering using the swql query editing the widget. Luckily we have custom properties for region, country, city to narrow it down and finally node caption to get the culprit. Drilled down to one node. Had a grey status icon but wasn't unmanaged. Decided to delete and rediscover the node which solved the issue.

Thanks for thinking along though.

Cheers, John
0 Kudos