cancel
Showing results for 
Search instead for 
Did you mean: 
Create Post
Level 8

Node is currently down, unreachable or provided credentials are not valid

Node is currently down, unreachable or provided credentials are not valid

Hi All, have the above issue.

Background is;

     Devices monitored - Cisco Switches ranging from 2960's to 3850's varying IOS levels.

     Monitoring is currently fine on all listed devices.

The node is not refreshing, and if I try to list resources I get the error Node is currently down, unreachable or provided credentials are not valid.

All switches are using the same SNMP v3 credentials, however this is only happening on a few random switches. 

One stack I removed and tried to re-add still had this issue.

I've tried a warm restart of SNMP on another switch stack, and still have the error.

The only thing that seemed to fix it to re-added the deleted node was a reboot of the orion server.

Using Orion 2018.2 SP3

NPM 12.3

0 Kudos
12 Replies

same issue was faced, snmp walk working fine with v3, but unable to do List resources even force refresh it shows same error "NODE IS CURRENTLY DOWN, UNREACHABLE OR PROVIDED CREDENTIALS ARE NOT VALID"

Restart of only Orion Services resolved the issue, were able to do List Resources on the node.

0 Kudos
Level 17

Are your devices dropping any packets? Check your snmp stats on the switch in question to see how many requests make it to the box and if any are dropped.

show snmp

Turn off Prime for this node to see SW counts, and since you can not reset the snmp counters without a reset check those #'s first for reference.

-CharlesH

Loop1 Systems: SolarWinds Training and Professional Services

0 Kudos

Tried deleting node and re-adding failed

Tried snmp2 worked

back to snmp3 failed

reboot orion server worked.

This is obviously an issue with orion, as a reboot of the orion server is all that fixes the issue, until it re-occurs

Interesting. Does the issue happen with the same nodes over and over, or does this seem to be rotational and you just never know which node goes dormant until it does?

Any of the devices have snmp being dropped showing in their logs?

Is there an initial Success with SNMP v3 on the test and even polling after submit, but it drops sometime after - or no response at all after submit?

Sorry if any of this is a repeat of what you have gone through - but I did not see these details in the thread.

0 Kudos

I've done a packet capture on our orion box.

On a normal device I see full communication.  On a fault I seen SNMP request, I see SNMP reply, then ORION does nothing else

If I debug SNMP packets, I see snmp requests come in from orion, and the responses return.

eg.

Aug  7 09:14:38: SNMP: Packet received via UDP from 10.n.n.n on VlanABC

Aug  7 09:14:38: SNMP: Report, reqid 38967, errstat 0, erridx 0

usmStats.4.0 = 14591517

Aug  7 09:14:38: SNMP: Packet sent via UDP to 10.n.n.n

Aug  7 09:14:38: SNMP: Packet received via UDP from 10.132.40.86 on VlanABC

Aug  7 09:14:38: SNMP: Report, reqid 2147483647, errstat 0, erridx 0

usmStats.5.0 = 14533689

Aug  7 09:14:38: SNMP: Packet sent via UDP to 10.n.n.n

This is the packets during the test button press in edit properties.

0 Kudos
Level 10

We have the same issue.


Question-   do you have multiple pollers?    It is only impacting one of our additional pollers.  If we move the device to another poller- it works fine.  We only encounter this error when we go to to "list resources". 

0 Kudos

Just a single polling device.  I get the issue under list resources, or edit settings.  But it carries on monitoring perfectly fine.

0 Kudos
Level 16

it would be good idea to check whether SNMP is responding on these switches.. in most of the cases, this happens becoz Solarwinds is not able to connect to the devices over the protocol mentioned...

0 Kudos

SNMP works fine with other products, such as Cisco PRIME, using the same credentials

0 Kudos

from other source if its working, thats different thing...

did u try changing the community string and test and what is timeout setting for SNMP set to?

0 Kudos
Level 16

Can you try running an SNMP walk from the Orion server to the nodes that are having issues and see if it connects?

SolarWinds SNMP Walk: A new tool for collecting SNMP MIB walks - SolarWinds Worldwide, LLC. Help and...

0 Kudos

MIB walk runs fine and I get all the required responses.

As I say a reboot of our Orion server fixes it, temporarily, and it's random switches the error occurs with.

0 Kudos