Showing results for 
Search instead for 
Did you mean: 
Create Post
Level 11

Network Topology Issues

We have a multi vendor network and are struggling to get accurate topology information on any equipment other than our Cisco estate.

We have multiple subnets and on Cisco only subnets the topology information is reported correctly.

However in other subnets where we have multi vendors we struggle to get accurate topology information, some devices report their information where others don't.

e.g. we have 2 Cisco Distribution switches that run spanning tree on 2 seperate rings on a subnet, a very brief layout is below

Vendor A -> Vendor B -> Vendor B -> Vendor B -> Vendor B - Vendor B -> Vendor A

On the above scenario we have toplogoy information from 1 to 2, nothing from 2 to 3, nothing from 3 to 4, information from 4 to 5, nothing from 5 to 6 and information from 6 to 7.

Vendor A is Cisco, Vendor B is Garrettcom and the links between switches are fibre.

Each node has both the L2 & L3 boxes ticked under resources and in the back end database i can see the L2 connections for each of the nodes.

In the database however under the toplogy table i only see some of the links being reported.

Using Network Atlas (ConnectNow) or NTM show the same results.

The vast majority of these nodes have been added manually, however i have tried running Network Discovery to see if the toplogy information can be recalculated but no matter what i try i cannot get this information to show.

We will be in a position shortly to upgarde to the latest version of NPM (currently running V12.1).

Question is do i upgrade the software from 12.1 to the latest, or trash my database and start again from a fresh install of the latest version and then re-import all of my devices again and start over using Network Discovery to add my nodes.

Or is there some other way of getting the topology information to be displayed on a mixed vendor subnet without too much effort?

Any ideas / suggestions would be appreciated.

Labels (1)
0 Kudos
5 Replies
Level 16


Before open a ticket with support.

make sure that your cisco and Garrettcom  are  supporting those mibs that needed with that tool

:\Program Files (x86)\SolarWinds\Orion\PollerCheckerTool

If yes.

Try to enable LLDP on Garrettcom  & Cisco so they run the same disco protocol.

Then if it's still not working make a ticket.

0 Kudos

Hi sja,

Firstly many thanks for your reply and suggestion.

I'm not that familiar with the PollerCheckerTool, so not entirely sure what options to check, however saying that I have ran it against some of the nodes I have issues with.

Attached are 2 images - 1 called Cisco that does show the topology information and 1 called Garrettcom that doesn't.

The Garrettcoms themselves through their own web interface do show LLDP discovery information and on what ports it has seen it, but in the attached picture (Garrettcom) in Solarwinds I only see the Topology information for L2 reported between SW/096 & SW/142, I see nothing between the others - the path is 096 - 142 - 141 - 258.

Are you able to advise what options I should check to poll and if the other devices aren't showing these as being enabled (red) can I enable the ones that are required? If so what ones are required? is it the lldpRemoteSystemsData that requires to be enabled on all switches?



0 Kudos


The lldpRemoteSystemsData is the neighbors info (what we looking for when LLDP is enable)

like  cli "show lldp neighbors"

Do you have 2 Garrettcom that are neighbors (point 2 point) ?

If yes  and it's working so LLDP is not the problem.

0 Kudos


Yes we have in this subnet a string of 5 Garrettcom devices connected to each other in turn.

LLDP is enabled on all Garrettcom devices and the switches themselves show the neighbour information.

However within Solarwinds, it only shows the topology information above on the first SW/096 connecting to SW/142, it doesn't show anything for 142 to 141 or for 141 to 258 etc etc.

0 Kudos

Sound like support ticket...

0 Kudos