cancel
Showing results for 
Search instead for 
Did you mean: 
Create Post
Highlighted
Level 9

Re: NPM 12 Stack Data Ring error

Jump to solution

Nvm figured it out!

0 Kudos
Highlighted

Re: NPM 12 Stack Data Ring error

Jump to solution

There are some guidelines for building Cisco stacks that might improve your experience:

pastedImage_2.png

0 Kudos
Highlighted
Level 8

Re: NPM 12 Stack Data Ring error

Jump to solution

Is that recommendation from Cisco documentation ?

0 Kudos
Highlighted

Re: NPM 12 Stack Data Ring error

Jump to solution

Re: NPM 12 Stack Data Ring error

Jump to solution

I appreciate the references which are helpful, but I've got multiple stacks all configured similarly that consist of a varying number of  switches with some reporting and some not. It seems like certain stacks are reporting accurately and some are not.

Highlighted

Re: NPM 12 Stack Data Ring error

Jump to solution

I bet if you opened a TAC case, Cisco would tell you to upgrade the IOS.  A pretty standard response . . .

Highlighted

Re: NPM 12 Stack Data Ring error

Jump to solution

This is more of an oversight on my part, but I had stacks that were not reporting data rings on SW, but reported power stack ring. Turns out I had "ghost" switches provisioned when I had upgraded a stack and divided them later. After unprovisioning the switches and rebooting. SW now reports correctly. Just a heads up from an unobservant net admin

Highlighted

Re: NPM 12 Stack Data Ring error

Jump to solution

3850's running 3.6.4.E are good:

pastedImage_0.png

2860X stacks running 15.2.4.E1 are cool:

pastedImage_0.png

Highlighted

Re: NPM 12 Stack Data Ring error

Jump to solution

Dan,

I finally got the error message you are receiving but mine is on a stack of 9 3850s running 03.06.03E. I've checked the poller, but depending on your settings if the poller isn't assigned to that device (atleast in my setup) then the stack tab doesn't even show up. One thing I did find strange as I was investigating this was one of my stack rings is apparently not reporting/using power...more issues yay See below

#sh switch detail

Switch/Stack Mac Address : dceb.9440.4600 - Local Mac Address

Mac persistency wait time: Indefinite

                                             H/W   Current

Switch#   Role    Mac Address     Priority Version  State

------------------------------------------------------------

*1       Active   dceb.9440.4600     15     V04     Ready

2       Member   dceb.9440.4680     1      V04     Ready

3       Member   b07d.47b7.2380     1      V04     Ready

4       Member   bc16.f503.f800     1      V04     Ready

5       Member   dceb.9420.fc80     1      V04     Ready

6       Member   2834.a2fc.8680     1      V04     Ready

7       Member   b07d.47e0.9d80     1      V04     Ready

8       Member   b07d.47a7.cc80     1      V04     Ready

9       Standby  dceb.9440.5080     14     V04     Ready

         Stack Port Status             Neighbors

Switch#  Port 1     Port 2           Port 1   Port 2

--------------------------------------------------------

  1         OK         OK               2        6

  2         OK         OK               3        1

  3         OK         OK               4        2

  4         OK         OK               5        3

  5         OK         OK               9        4

  6         OK         OK               1        7

  7         OK         OK               6        8

  8         OK         OK               7        9

  9         OK         OK               8        5

stackdata.PNGstackpower.PNG

sh stack-power

Power Stack           Stack   Stack    Total   Rsvd    Alloc   Unused  Num  Num

Name                  Mode    Topolgy  Pwr(W)  Pwr(W)  Pwr(W)  Pwr(W)  SW   PS

--------------------  ------  -------  ------  ------  ------  ------  ---  ---

Powerstack-1          SP-PS   Ring     4290    42      4248    0       3    6

Powerstack-11         SP-PS   Ring     4290    34      4256    0       3    6

Powerstack-12         SP-PS   Ring     0       0       0       0       0    0

Highlighted
Level 11

Re: NPM 12 Stack Data Ring error

Jump to solution

beardedgeeknc, maybe problem is your stack cabling/configuration ?...

yours...

stack_1.jpg

Mine...

stack_2.jpg