cancel
Showing results for 
Search instead for 
Did you mean: 
Create Post
Product Manager
Product Manager

NPM 12.3 Orion 2018.2 Upgrade Feedback

What has your upgrade to NPM 12.3 on Orion Platform 2018.2 looked like? We on the product manager team would like to hear about it all, the good the bad and the ugly! For a starting point here is a quick getting started blog post on upgrading to 2018.2 Orion Platform: Preparing for the Upgrade to 2018.2

Tags (1)
310 Replies
Product Manager
Product Manager

aLTeReGo I know there are several obvious differences we are each having, some even being on different NPM versions (12.2 vs 12.3), but a few of our symptoms seem to be oddly similar. I'm not sure if nafees.khan or Deltona already have cases open (for the missing interface stats), but if it helps, here is my case for that issue. I am currently running wireshark on my APE, in hopes to capture something the next time the issue appears.

Case # 00082603 - Our SolarWinds environment appears to have unexpectedly stopped polling interface statistics last week.

This case was created on 2018.04.09, and I first noticed the issue a few days prior.

Thank you,

-Will

wluther, your case 00082603 appears to have been closed due to 22 days of inactivity. If you continue to have this issue, please open a new case with support so we can assist with determining the cause.

0 Kudos

aLTeReGo​ The issue is definitely still occurring, and I have been replying to the support emails. My support window shows it in progress, but it may have been reopened. Would it be best to simply open a new case?

0 Kudos
Product Manager
Product Manager

wluther  wrote:

aLTeReGo  The issue is definitely still occurring, and I have been replying to the support emails. My support window shows it in progress, but it may have been reopened. Would it be best to simply open a new case?

Your last update to the support case two days ago stated

I have been running the capture since last week, however, the issue has not occurred again since. I will clear the results and start a new capture. I will let you know as soon as the issue occurs again

Is the issue still occurring? If so, please update the case so the support engineer is aware.

0 Kudos
Level 11

I had opened a case on 2nd April 2018, on 24th March I upgraded to SAM 6.6, still is the issue is not resolved

Issue is random, we have single main polling engine, post rebooting the server or restarting the services, interface statistics polling starts for few hours/days

Support has reinstalled collector and job engine multiple times

They have also replaced polling engine SDF files post which issue takes longer time to reoccur

0 Kudos
Level 11

Are you still facing this issue,?

I am facing this issue since the upgraded to SAM 6.6

Installed NPM is 12.2

0 Kudos
Product Manager
Product Manager

Deltona , this is certainly not normal/expected behavior. Nor am I aware of any other customers reporting similar issues. Have you opened a case with support?

0 Kudos
Level 9

We are experiencing the same issue in our environment. We have opened a ticket but no solution given yet

0 Kudos

I wasn't able to update our Additional Polling engines using the scalability installer (downloaded from the Polling Engines page).

The issue was in the installer not being able to download the OrionImprovement.msi or the OrionImprovementOptIn.exe from the main server (reported).

The administrationservice.client.log - however - presented a different reason. It stated that the setup wizard on the APE failed because it couldn't download the OrionImprovement files from:

https://downloads.solarwinds.com/solarwinds/CatalogResources/OrionImprovement/.......

"SolarWinds.Administration.InstallExecutor.Executors.DownloadExecutor - Can't download file"

Why is the scalability installer downloading binaries online? Not that there wasn't any internet connection on the server (there was), but this shouldn't happen.

The scalability installer should download the file from the primary server and NOT from an online source.

Digging deeper into it I found that the manifest is trying to download older versions of these files than exist on the primary server.

For example, with the OrionImprovementOptIn.exe file, it wanted to download /2.8/2.8.0.196/OrionImprovementOptIn.exe, while the version in use and available on the primary server is 2.8.0.232.

Copying these two files from the primary server and manually placing them in the installers and downloads folder did not resolve the issue. The scalability installer still failed during the Installation step.

I resolved the issue by manually installing each required service installer on the additional polling server.

0 Kudos
Product Manager
Product Manager

The log message is actually inaccurate. I double checked with my team and we are not downloading a file from the internet in this scenario. It does look like you've run into an issue that both wluther​, silverbacksays​ had given me more information on and diagnostics, so this should be resolved. Thanks for sharing your experience and detailed workaround.

0 Kudos
Level 9

Since the upgrade it seems that my widgets are gone... only the once created by myself are visible. Here is a view of editing a overview of a nexus device:

pastedImage_1.png

0 Kudos
Product Manager
Product Manager

I can honestly say you are the first customer to report this. Have you opened a case with support over this issue?

0 Kudos
Level 9

Not yet, i wanted to see if anybody else have the same problem, or if it is a setting which is wrong. I'll open a ticket then... Thanks for the reply.

0 Kudos
Level 9

The upgrade was mostly successful, Had an issue with the 'Solarwinds WPM Playback Player Proxy' service stopping and restarting after the upgrade to 2.2.2.

The remote player could not connect back on TCP:17782, The local players were fine.

There were 2 files not present in the 'C:\Program Files (x86)\SolarWinds\Orion\SEUM' folder as shown in the logs.

2018-06-07 09:48:45,466 [4] WARN SolarWinds.Orion.Common.Helpers.CryptoHelper - Unable to load SolarWinds.Orion.Security.dll from execution directory.

  1. System.IO.FileNotFoundException: The system cannot find the file specified. (Exception from HRESULT: 0x80070002)

   at System.Reflection.RuntimeAssembly.nLoadFile(String path, Evidence evidence)

   at System.Reflection.Assembly.LoadFile(String path)

   at SolarWinds.Orion.Common.Helpers.CryptoHelper..cctor()

2018-06-07 09:48:45,466 [4] WARN  SolarWinds.Orion.Common.Helpers.CryptoHelper - Trying to load SolarWinds.Orion.Security.dll from Orion install directory...

Copied the 2 missing files Solarwinds.Orion.Channels.dll and Solarwinds.Orion.Security.dll to the 'C:\Program Files (x86)\SolarWinds\Orion\SEUM' folder and the issue was fixed.

0 Kudos
Product Manager
Product Manager

Hello, thanks for the details. Have you already opened a support ticket on this issue?

0 Kudos
Level 9

Where did you find the missing files? I have checked my main pollers, and my APE, and none of them have those files to copy over.

0 Kudos
Level 9

The upgrade was successful. We had NPM,NCM,VNQM,NTA & UDT updated to the latest version. Our main Orion DB is still 2014, however managed to get 2016 SQL installed on a separate server just for NTA.

Just to understand regarding the new Orion Maps feature. How it captures the details, which protocol it is using to come up with the automated maps?  When checking a Nexus 7k device, it seems to capture more device which are not physically connected.

Level 10

So we are facing an upgrade situation which I don't think is covered in any of the scenarios I have seen and wonder if anyone has any advice.

We have NPM 12.1, NTA 4.2.2, NCM 7.6, SAM 6.4, VNQM 4.4.0, SRM 6.4 and will add VMAN during this upgrade.

On 1 x PPE, 8 x APE, 4 x AWS, 1 x FSDB

We have two complications to get over.

1. Although our Orion DB is SQL 2016Sp1 we cannot upgrade to NTA 4.4 as we cannot afford to loose the last 90 days of NTA data without more time to mitigate the impact to customers. (Why o why is their no data migration option??)

2. Our PPE is currently on 2008R2 and we have to migrate to a new 2012R2 Server at the same time (keeping the same name and Ip)

On the new server (that will become our PPE) the falcon installer should work by installing/upgrading all the modules but if we cancel the upgrade to NTA 4.4 will it install/upgrade NTA to 4.2.3 even though NTA has never been on that server? Does the NTA FSDB server need to be upgraded to 4.2.3 first?

One workaround suggested was to run the falcon installer on the new PPE and select all modules except NTA, complete that installation/upgrade and then come back and use the direct NTA 4.2.3 install file to upgrade the FSDB server, then the PPE, then all the scalability engines again.

It would be nice to hear if this scenario has been thought of and is covered by the installer or if anyone else has done something similar?

Thanks

T

Product Manager
Product Manager

Hello Tony!

"we cannot afford to loose the last 90 days of NTA data without more time to mitigate the impact to customers' <-- one option you could consider since you have a 2016 db ready is as follows:

1. upgrade everything to NPM 12.3 & NTA 4.4 to start polling and collecting data

2. set up an evaluation separate instance of NPM 12.2 & NTA 4.2.3 to point to the old NTA 4.2.3 fastbit data. This would be used for the next 30 days while you build up monitoring on your existing install. The evaluation instance of course is valid for 30 days and would give you access to your existing historical data.

"Our PPE is currently on 2008R2 and we have to migrate to a new 2012R2 Server at the same time (keeping the same name and Ip)"

I honestly would recommend that you go to 2016 if possible. Microsoft has already announced end of support for 2012 R2 in October of this year, so you might as well save yourself some future upgrade headaches by going straight to 2016 if you're doing a rebuild.

0 Kudos
Level 10

Lets try to get the NTA migration tool we really need - thanks for your support:

0 Kudos
Level 17

Run the online installer, you can get to and hold NTA at 4.2.3 using the "Cancel" option, and confirming it(see my comment below for insight).

0 Kudos
Level 10

Thanks for that info cahunt. That's what we had planned originally but we are nervous about how the installer will handle the fact it will be a new server with no record of the current NTA version.

Where you installing on a fresh PPE server or doing an in place upgrade?

Thanks

Tony

0 Kudos