cancel
Showing results for 
Search instead for 
Did you mean: 
Create Post
Product Manager
Product Manager

NPM 12.3 Orion 2018.2 Upgrade Feedback

What has your upgrade to NPM 12.3 on Orion Platform 2018.2 looked like? We on the product manager team would like to hear about it all, the good the bad and the ugly! For a starting point here is a quick getting started blog post on upgrading to 2018.2 Orion Platform: Preparing for the Upgrade to 2018.2

Tags (1)
310 Replies
Product Manager
Product Manager

It may help us to better identify a trend if when posting you include not only the symptoms you're seeing, but also the modules you have installed. It's possible that this issue is only affecting a subset of customers who own a particular combination of product modules.

0 Kudos

So on Friday night at 10:38PM I received my last alert from Solarwinds.  I just ran the diagnostics tool and it was complaining that Orion could not find the SQL server - which was kind of odd seeing that I can ping back and forth on each server via DNS name and IP address.  I just rebooted Orion and now it i sending out alerts from over the weekend.... At this point I am going to open a ticket and hopefully get someone to assist in this mess. 

0 Kudos
Level 10

I am not sure if others have seen this, but I do have support case 00114483 open on it.

I did the upgrade to SAM 6.6.1 (and several other modules), and all went fine during the upgrade.  About 15 hours later, we received a large amount of false positives for HTTPS Monitors.  We use a lot of HTTPS monitors in SAM.  I had to restart all services to get things back to normal.  The next day, the same thing happened.  After that, I opened the support case above.  Since then, it happens about every 15 hours.  I have been restarting services every 12 hours or so, which is the best way to remove any false positives.

Any guidance from the team is helpful, as support has yet to find a fix.  We have checked a number of logs and uploaded them.

I don't believe the port issue is the problem, as we do not have very many unknown / down apps.  All agents are working fine as well.

0 Kudos
Product Manager
Product Manager

darlonjeel  wrote:

I am not sure if others have seen this, but I do have support case 00114483 open on it.

I did the upgrade to SAM 6.6.1 (and several other modules), and all went fine during the upgrade.  About 15 hours later, we received a large amount of false positives for HTTPS Monitors.  We use a lot of HTTPS monitors in SAM.  I had to restart all services to get things back to normal.  The next day, the same thing happened.  After that, I opened the support case above.  Since then, it happens about every 15 hours.  I have been restarting services every 12 hours or so, which is the best way to remove any false positives.

Any guidance from the team is helpful, as support has yet to find a fix.  We have checked a number of logs and uploaded them.

I don't believe the port issue is the problem, as we do not have very many unknown / down apps.  All agents are working fine as well.

Thank you Lance, I've sent this over to the SAM team to see what the team has to say about it.

0 Kudos
Level 12

Does one need to upgrade to platform 2018.2 before upgrading NPM to 12.3? I'm showing Orion Plaform 2017.3.5 SP5 and I'm on NPM 12.2. Or does the upgrade to NPM 12.3 take care f the platform also?

0 Kudos
Product Manager
Product Manager

jameslindsay  wrote:

Does one need to upgrade to platform 2018.2 before upgrading NPM to 12.3? I'm showing Orion Plaform 2017.3.5 SP5 and I'm on NPM 12.2. Or does the upgrade to NPM 12.3 take care f the platform also?

Just upgrade to NPM 12.3, and the platform comes along for the upgrade. No separate step needed on your part at all.

0 Kudos
Level 9

After running the new version since a couple of days now, i have a lot more "unexpected Website-errors", which is gone when i reload the relevant page. Usualy i get this error when i open a Nexus device, it seems that to much data are getting pulled from the database and the page gets a timeout then.

0 Kudos
Product Manager
Product Manager

andreasw  wrote:

After running the new version since a couple of days now, i have a lot more "unexpected Website-errors", which is gone when i reload the relevant page. Usualy i get this error when i open a Nexus device, it seems that to much data are getting pulled from the database and the page gets a timeout then.

out of curiosity when you see the unexpected website errors - what is shown in the logs for you?

0 Kudos

Upgraded last week, here are the thoughts and suggestions from my organization

the new look of alerts is nice and bright

we wish you could display more than 5 alerts at a time

the new manage entities page is not being received well, there is a bit of a learning curve to get used to it and how to find common things,

one the biggest is nodes that are unknown or are missing a custom property, i  used to be able to sort by custom property and it would show a list of "unknown" where devices that haven't been assigned one of those properties would be

Product Manager
Product Manager

thebrianwilson4  wrote:

the new manage entities page is not being received well, there is a bit of a learning curve to get used to it and how to find common things,

one the biggest is nodes that are unknown or are missing a custom property, i  used to be able to sort by custom property and it would show a list of "unknown" where devices that haven't been assigned one of those properties would be

Great feedback thebrianwilson4 and nice catch. I've logged this internally under OADP-202.

Level 8

Im busy planning my upgrade and have the following question.

The current setup is that NPM, NCM and IPAM use the same database.

NTA 4.2.3 uses the other Fastbit database located on a different server.

Now, when upgrading NTA to 4.4.

Can I point NTA 4.4 to the same SQL database that NPM, NCM and IPAM is using?

Or do I need to create a separate database on the same server?

0 Kudos

NTA 4.4 needs its own database and it needs to be on SQL Server 2016. If your existing SQL Server is 2016 then you can host the new database on the same server instance but it will have its own MDF/LDF.

- David Smith
Product Manager
Product Manager

NTA 4.4 requires the use of a separate database, but the same SQL server and SQL instance may be shared between NTA and rest of Orion.

Can I call Jinx?

- David Smith
0 Kudos
Product Manager
Product Manager

Not with a 6min delay.

Level 13

I can't believe that during this process you never had a problem.  For the last week I have had consistent issues with the front end dying.  Today, after numerous reboots, services stopping, configs and rebuilds, after 3 hours, I have managed to get it running.

I have calls open and there doesn't seem to be a permanent fix for this.

Product Manager
Product Manager

We've been looking into this thread and following up on the customers who were kind enough to provide their support tickets (yours included). A few customers seem to be running into symptoms of port exhaustion Ephemeral Port Exhaustion - SolarWinds Worldwide, LLC. Help and Support  but we're working through support to identify those folks and give them more tailored guidance. I am following the updates on your case in particular.

I have had the port exhaustion issue happen before on my Orion server prior to the last update I ran.

This upgrade has been horrible.

I have had several issues and several support tickets open with no clear answer. I am still fighting to move my support case up the chain. I've sat on the phone all last week running different configuration wizards, reinstallations and re-creations of the database which is further breaking my system. Currently, Solarwinds is not usable for almost two weeks. I have sent numerous diagnostic files with no clear answer.

Upgrade:

Upgrade from Win 2008 R2 > Win 2016

Upgrade from SQL 2014 > SQL 2017

Upgrade ALL Solarwinds modules to the latest versions

     Orion Platform 2018.2.1 SP1, VNQM 4.5.0, IPAM 4.7.0, NPM 12.3, VMAN 8.2.1 SP1, NetPath 1.1.3, CloudMontitoring 2.0.1, SAM 6.6.1, NTA 4.4.0

Purchase and install an APE.

Issues:

1. JobEngine v2 stopping/starting with errors "out of memory" when sufficient memory is on every system/server.

2. IPAM not scanning ANY subnets

3. Extremely poor web page performance (especially on first load of web page) & web page timeout errors.

4. Netflow upgrade unexpectedly wiping ALL netflow data for upgrade into SQL and then copying the entire main database to the netflow database.

5. Error adding new nodes.

6. Website path \inetpub\orion\solarwinds  is very 'jumbled' and does not have the proper structure as it previously had. I'm missing a ton of files in here.

7. Recieving random out of memory errors when my system is sitting at 30% memory used.

0 Kudos
Product Manager
Product Manager

Darcy,

Just for a quick clarification - it sounds like your whole system is upgraded to the product versions that you listed, and you installed an APE. Is all of the setup and upgrade completed and now you are dealing with a system that is not working?

Can you send me the latest support ticket you have filed?

"I am still fighting to move my support case up the chain" <-- I'm sending your description of your woes over to support management, as that's not the intended experience for our customer base.

0 Kudos

Hi Serena,

Thank you for the quick follow up. Much appreciated!

The setup and upgrade is all complete. I've worked with numerous technicians to confirm this (because yes, we did a big upgrade).

Here's my case numbers:

00113255

00114926

00115779