cancel
Showing results for 
Search instead for 
Did you mean: 
Create Post
Level 14

NPM 12.2 Upgrade Experience Feedback?

Jump to solution

Anyone have any upgrade experiences for the general release?

We are looking to upgrade our entire SW suite in addition to NPM and would like to hear any feedback.

Also, is the RC code the same as the GR code?

Thanks in advance

Tags (1)
1 Solution
Product Manager
Product Manager

This thread has been super helpful and given us many conversation points and feedback. However, the thread is now gotten unwieldy and hard to parse through the feedback. I'm locking this thread and for those of you who are participating in our RCs, invite you to come give additional feedback on my post  Orion Platform: Preparing for the Upgrade to 2018.2  in the NPM release candidate forum. Once we are out of RC, I'll be starting a new topic thread for upgrade feedback for NPM 12.3.

Thank you and for those of you with whom I have ongoing conversations, we'll find other avenues to move forward on those topics.

View solution in original post

224 Replies

Agreed.  It sounds like you've experienced many of the things I did during my upgrade.

More interesting (to me) is the fact that running certain hot fixes followed by the Scaleability Engine updates on the pollers resulted in dual Wizards opening on every APE.  Running each simultaneously guaranteed both to fail.  Running the first one all the way through to completion, even though the other Wizard popped up part way through, was the path to success.  Once the first Wizard was successful, then running the second to the end would work.  It's crazy that two would show up at the same time.

Perhaps simpler to fix, but harder to recognize, was that the Wizards would pop up BEHIND the NPM front end page.  Definitely a loss of time discovering all the Wizards had started up behind the browser window.  I figured I'd messed up somehow, and tried starting them again.  Which failed.

By accident I was moving the browser about the RDP window and discovered the Wizard waiting for my input behind ID.  Hmph!

"because I'm a packrat, and maintain on-disk copies for just this eventuality"

I do this both at work and home.

I always feel bad about doing it (wasting both my time and disk space) and then once in a blue moon it really pays off nicely.

I really wish vendors (everyone who releases code) would always provide a way to get to old releases so I wouldn't have to do this, but I've been bitten just enough to not even trust them if they did

0 Kudos
Level 7

The upgrade was smooth, I liked the new monitoring for ASA and I see a great future for that, but I am also having the same issue as I see many people complaining regarding Health Monitoring at some of my ASA's.

I have opened a ticket to check that and the conclusion was that the IOS version of the devices I am having trouble are older than the ones that are showing the information correctly.

OK, I understand that but before the firewall insight feature, it was possible to verify these sensors at that devices. And I cannot simply go ahead and upgrade many devices that are currently running stable only to correct monitoring system problems.

I hope there is a hotfix coming soon.

I checked out the Shared Thwack Pollers and found one that provided much more ASA hardware & interface information.  I tested it and found it compatible with my ASA's.  Downloaded it, applied it, and now my firewall admins are significantly more impressed with NPM.

Check it out, see if it is good for your ASA's.

There IS a hot fix available for NCM 12.2; I don't know if it addresses your ASA issues, though.  Check it out and apply it--it sounds like it's helped plenty of people already.

I recently upgraded to NCM 12.2, and applied the hot fix.  The only issues I've seen so far have been my ASA 5525-X models aren't getting the right hardware (CPU/Memory/Fan/Temp) polling anymore, and the default views of classes of nodes don't automatically include latency graphs.  Those are VERY easy to add into NPM's views, and applying it to one ASA's views applies it to all ASAs views.

There's definitely a learning curve to cover the ways I saw & did things with NPM 12.0.1 and 12.2.  But it's been pretty intuitive, and the installers are only getting easier and more comprehensive.

I worked with Solarwinds Technical Support today on a different topic, and learned that a new, more-global upgrade / hot fix installer is being developed and used/tested in-house at SW.  It sounds wonderful, and I bet by this time next year we'll all be able to use it to upgrade and patch multiple servers & pollers & Orion applications with a single click.

pastedImage_0.png

Level 20

I'll have to watch this thread...

Level 7

Hello,

We've some serious problem after the upgrade from version 12.1 to 12.2.

The installation part was fine without any error but the license store is now corrupted.

We tryed to follow this thread :

https://support.solarwinds.com/Success_Center/Orion_Platform/Orion_Documentation/Corrupted_license_s...

However we have an error when trying to launch migration.exe /ExpireAll command , reporting that The license store is not in valid state

Anyone have this problem?

We've already opened the Case #1295467 but we're still awaiting an answer from the support service .

Thanks in advice

Level 9

Performed the upgrade this afternoon (NPM, UDT, NTA, NCM).  Installer went smoothly and probably around an hour.  NPM 12.1 was the old platform and Win 2K16 server.

Unfortunately, it created havoc in my environment.  My most critical ASA 5520 failover pair became unusable and started rebooting.  I had to unmanage them in Orion to get them stable again (after powering off each as Orion was reporting them with dead fans and temp warnings as well as the reboots). It also caused a number of Cisco APs in my environment to become unresponsive and reported them as rebooting repeatedly.  The telnet/SSH console was so unresponsive that I couldn't manage to login.  Changed them to ICMP only polling and service was restored.

Also have a Citrix SD-WAN appliance with a similar symptom and reporting in Orion as rebooting every 30 minutes now. I checked the appliance and it doesn't appear to be restarting so this may be a SYSUPTIME reporting issue, although I have 4 other SD-WAN appliances on the network that aren't reporting issues...

I have a case open and awaiting feedback.... beware on upgrading your prod environment.

PS: I noticed some else reported the 0C temp reporting on their ASA.  I have a 5525-X failover pair reporting the same.  It is also reporting the fans are all spinning at 0 rpm.  Might need to report that as well.

Cheers,

Aaron

0 Kudos
Product Manager
Product Manager

Can you send us your support ticket #?

0 Kudos

Hi Serena,

I have just just found that the "default" view for a device that is not identified correctly is now "ASA View".  So all the Access Points I moved to ICMP polling and any not using SNMP is displaying in ASA view which is completely useless for anything other than a ASA firewall.

I might log another ticket to get the default views restored.

EDIT:   Found the setting in views and found the "unknown" view had changed to "Node Details ASA Summary" during the upgrade.  Changed this back to "Node Details - Summary" and issue resolved. 🙂

Thanks,
Aaron

During upgrade we do a background inventory to find out if there are some ASA nodes that supports new ASA pollers.

If ASA pollers are discovered for some nodes, we assign new ASA view to their MachineTypes (ViewsByDeviceType) if they are set to “default”.

It looks like there has to be some node with Unknown MachineType (at least before upgrade) that supports ASA pollers, so we have changed a view to “ASA view” for “Unknown”.

If you want us to investigate further, please create a ticket and upload diagnostics.

Thanks,

  JP

0 Kudos

Thanks Serena.  My ticket number is 1300154

0 Kudos

If I might be so bold as to offer Installer Error Reports suggestions:

  1. It's unnecessary to indicate "we detected a problem."
  2. The largest text on the page should be applied to the actual problem.
  3. The robot overwhelms the page, indicating a problem, but no solution.  In fact, no one here knows how to help a dazed robot, so we're left stunned & confused too.  Although the robot IS pretty cute.
  4. Lose the "Close the installer" link, and replace it with the instructions necessary to diagnose, troubleshoot, and correct the problem.  A link to installer logs might be useful, if those logs stated the problem, like "A duplicate version of ActiveDiagnostics version 12345 was detected.  Cancel this installation of that same product and restart the process, skipping installing ActiveDiagnostics", or the equivalent.

pastedImage_1.png

Level 11

so i went with the upgrade just now   i have npm, ncm, ipan and udt

and this is the error i got, and now i have a complete  unusable system

pastedImage_1.png

0 Kudos

I get this on mine.The new installer needs some work

pastedImage_0.png

0 Kudos

When you get this, which installer are you running? You can get around this error by uninstalling Active Diagnostics and then running the installer again.

0 Kudos
Product Manager
Product Manager

"I have a complete unusable system" At this point in the installer, nothing has changed on your existing installation. Can you clarify what you mean by "unusable system"?

You can get around this issue by uninstalling IPAM. Don't run the configuration wizard when you remove the product at this stage. Then, you would run the 12.2 installer again. On the first screen, expand "Select Additional Products" to select IPAM. This will install IPAM + upgrade your existing system all in one go, and you'll be up to date on the latest.

I think I owe my problem free upgrade to Serena's advice about uninstalling IPAM first.  I followed this instruction on my primary Orion server and all additional pollers.  I did not see this advice in any documentation and because of my installed versions the Product Update Advisor tool wasn't very helpful this time around.  Thank you Serena!

I upgraded from Orion Platform 2016.2.100, WPM 2.2.1, IPAM 4.3.2, NPM 12.0.1, DPA 10.2.0, QoE 2.2.0, VIM 7.0.0, SAM 6.3.0, NetPath 1.0.1 to pastedImage_0.png without any problems at all.  I have 2 additional webservers and pollers plus a VMAN appliance and I think I was all done in less than 4 hours.  Great experience with the new installer and it definitely pays to read Thwack!

0 Kudos

so, as i said,  nothing working, no NPM/NCM  nothing

i've now got it working again, after many hours of work

by uninstalling all the applications, then 1 by one installing them again

what a ballache

0 Kudos
Product Manager
Product Manager

would you be interested in sending us your diagnostics?

0 Kudos

Can you check in add/remove programs if you have two IPAM's installed.

0 Kudos