cancel
Showing results for 
Search instead for 
Did you mean: 
Create Post
Level 11

NPM 10.1 UCS Monitoring - Adding Blades, SNMP Possible?

Jump to solution

Hi,

great new feature! This bings big value to this product!
Since the documentation about monitoring UCS is not very extensive....

I have to add the Blades of my UCS, but the SNMP credentials of the fabrics doesn't seem to work here.
Do you know if I can query them via SNMP, or are they just pingable?

thanks,
Herwig

0 Kudos
1 Solution
Product Manager
Product Manager

If you drill down on the blade I believe, you can get the status of PSU/Fans

View solution in original post

59 Replies
Level 7
Hey, don’t want to create new topic yet. We have 4x UCS 6332 domains all running version 4. Snmp v3 and v2 snmpwalk timesout after retrieving few OIDs. Was anyone successful in monitoring UCS FI version 4 over SNMP?
0 Kudos

Right need some help on this

We have two UCS one on each site with two FI each but only one seems to be showing up correctly in solarwinds see below.

First off not sure why the one on the right doesnt bring back the response time, so went through the polling times and there were different so amended. This may take a while to update though.

Compared all settings from the ucs manager and the fi's, now the only difference i can find that on the working one on the left: FI's they have ucs credentials that look like its being pulled from somewhere as the tick box is greyed out?

pastedImage_1.pngpastedImage_2.png

Working FI but cant untick??

pastedImage_3.png

Not working FI has no details or checked?

So I think this is the issue the odd thing is the account thats used on the ucs is a different account to the FI so it isnt pulling it from there?

Any help would be appretiated

Thanks

0 Kudos

There has been a feature request to add Cisco UCS service profiles so that NPM will add more information.  Please go to feature requests and all of you go say that you would like the more people that respond the faster it will get added.

0 Kudos
Level 9

Hi all,

We have just got the lastes version for the UCS system into our DC, and that is great Fun stuff to play with

but one thing I am looking for is a proper way to make a good view in SW so that i am getting the right and correct info asap when I go into SW.

So what and how has all of your setup this in your SW system.

I am running the latest version of NPM 11.5 so that should be ok

Hope some one can share some light here for me. Also a great way to keep track on on the ip etc for the blades etc if that is only way to added this into SW. I was hoping that I could just add the USCM ip and then get all the rest of the info, but I guess I am wrong here

Looking forward to hear and see some feedback here

Thanks

Level 8

I'm in the same situation as odberg. I can't seem to find any recent/updated documentation for adding UCS to our Orion

Level 7

Any update on this issue?

Level 13

is there any update, please advise

i am at CL14 and want to raise this to the cisco and SW staff here

Level 17

Have we tried this with a recent FI firmware? We haven't been able to reproduce this with recent firmware revisions.

Level 7

I have been having significant issues with this running 2.2(1d) and NPM 10.7.  I have a clustered UCS.  When I add the cluster's virtual IP to Solarwinds, everything shows up as N/A, as shown in previous post screenshots.  I can successfully ad the fabrics (switch-a/switch-b), by utilizing snmp v2 and adding them separately.  However, the "Poll for UCS" returns a failure, which I don't think it should since the virtual IP is hosted by the two fabrics.  Additionally, the blades cannot be added at all.  What is missing (or at least is very difficult to find) is a document that explains how to configure solarwinds to communicate completely with a UCS.  I would appreciate any help you can provide on this matter.

Level 12

buranb did you get any answers to your questions - I'm in the same boat, i can add the VIP using UCS credentials, then add the two FI's using snmp fine, but when I try to click on the blades to add i can't.  I did find the document http://www.solarwinds.com/documentation/Orion/docs/SettingUpCiscoUCS.pdf to be somewhat helpful, but lacking on some of the intricacies needed to fully deploy this monitoring.

Level 7

Found something in the pdf that Jay pointed to. One of the first things it says is you can't do LDAP, but then it proceeds to tell you if you are doing anything other than local logins you have to put "usc-" in front of it I.E ucs-yourdomain\youruseraccount. I tried it and I'll be dipped....it picked right up. Why in the world you would have to put "ucs-" in front of it ...I dunno, but it works.

Level 8

I have the same problem as nrunge.  I have had UCS in place for a while now and a ticket in.  Fix it or remove the visibility.

Level 7

I have the same problem. 10.3.1. The SQL column IPAddress under the NPM_UCSFabrics column has a NULL NodeID and a no data in for the Fabric-A IPAddress. I can only see half of my UCS cluster. Awesome "production" feature you got here.

Level 12

well you should talk to Cisco about it

There is currently a bug in the Cisco software where their UCS switch IP address information is not correctly updated in the API they provide to monitoring agents. This bug leads to Out Of Band (OOB) IP addresses on the switches showing as N/A in Orion. Due to this bug the first step is to change the OOB address on the affected switch to another IP address temporarily (5-10 minutes) and save the change on the device side and then change it back to the correct value. This will resolve the issue.

You can see some threads on Cisco's forums as well


UCS API response - extIp not specified for one of the switches - Forums - Cisco Developer Community

UCS API response - extIp not specified ... - Cisco Community

Level 8

So when you edit the properties on the FI and set the checkbox poll for UCS, i'm assuming the listener port is SNMP but does the UCS feature require SNMP3 setup on the UCS Manager?

Level 9

When you enable the checkbox poll for UCS you then enter the UCS username and password for a user that you create in UCSM.  This uses HTTP to login and get data as well as SNMP to get other data "regular" node data.

As I was writing this I was thinking (as I haven't tested) but does the "poll for UCS" only use HTTP or does it role to HTTPS if HTTP isn't enabled (or vice verse).

I originally had HTTP disabled in UCS and tried to authenticate w/ 443 as the port.  It always failed.  I enabled port 80 and tested - worked. 

So I am going to go on record as saying HTTP (port80) only for UCS polling.  At this time.

Level 9

HTTP is enabled on the UCS to the VIP. However, no credentials I've yet supplied and no port I've yet stipulated will work. Can someone give me some direction?

Level 7

Be sure to disable HTTP to HTTPS redirect.  I have added a read-only user and it does work.

My problem is that the A fabric shows N/A regardless of what I try.  It is also not a clickable/hoverable link (whereas switch B is).  I have tried removing all three nodes (A fabric, B fabric, and virtual IP) - i've tried snmp v2 and v3.  Not sure what to do.  Even the NPM demo on the Solarwinds site has a UCS chassis with switch-A as N/A.  Anyone have any ideas?

link.

I have the same issue - I opened a case and really never got anywhere with the tech.  He refered me to this thread to see if I could work it out.

I have to assume this is a bug due to the fact that all of the content is being served up from the active FI that shows N/A.

I hope that this issue will be resolved at some point in an upgrade as well as add the functionality of associating a blade with a service profile name within Orion.  Its not always great when you see IP address is down and have no idea what blade that is.