cancel
Showing results for 
Search instead for 
Did you mean: 
Create Post
Level 7

My Orion Deployment issues

Hope this is the right discussion board.

Ever since we've had the ability to use the My Orion Deployment option. it has never worked. previously it couldn't connect to half my pollers, which were up and running perfectly fine. Support wasn't any help and said to update manually and wait until the next version came out that would resolve it.

Next upgrade to 2019.4, same thing. had to complete manually. It really wouldn't be an issue except we have 12 pollers, most in HA, so lot's of servers to manually complete.

Now I would like to install an evaluation using the "My Orion Deployment" option, however it just sits at "Connecting to Other Orion Servers"

Curious if anyone has had these issues before and a way to resolve them?

On to my next question, when installing an evaluation, like SAM or SRM, do I install on the main orion server only, or do we need to upgrade all the pollers?

0 Kudos
7 Replies
Level 7

found the issue, within the SWA_InstallationSession table, there was an active UpdateCheck from last month, it was stuck or something. Cleared it out and now I can get past the connecting to scability engines page. Will test on next upgrade how it goes.

0 Kudos
Level 13

In our environment, it was Port 1801 not being open between a brand new cloud APE and the primary that was causing the My Orion Deployment Issues.

https://documentation.solarwinds.com/en/Success_Center/orionplatform/Content/Core-Orion-Requirements...

 

0 Kudos
Level 7

We have all ports allowed between our Solarwinds servers. I reopened my original case, they said the reason is most likely all pollers aren't on version 2019.2 or later, but they are all on 2019.4, so I am good there. Hoping to hop on a webex with them to look.

0 Kudos
Level 10

You are not alone in this. My Orion Deployment Health, Updates & Evaluations, and diagnostics are all blank. I can see my servers, but all other pages are blank.

0 Kudos

Not sure what in your environment causes you to be unable to use the centralized upgrade, but for your question about the evals, you will need to install it on every polling engine to have them actually work.
- Marc Netterfield, Github
0 Kudos
Level 7

Not sure either. Kind of frustrating.

Going back to the evaluations, if we’re just doing a 30 day trial, will it work as expected to test out while just on the main server? Or are you saying the pollers still need to be upgraded regardless?
0 Kudos

It's been a while since I did something like that but I did install a module only on the main poller before. If you try to use a feature from that module on a node that didn't have the module installed it caused errors. If you were strategic you could probably work around it but I think it could get a bit messy.

I generally do all my evals on separate systems because removing them after the fact if you decide not to buy the module can be a pain. I've had a client who eval'ed a module years ago and when I came in to install the current version we had to purge a ton of old incompatible tables from the db.
- Marc Netterfield, Github
0 Kudos