cancel
Showing results for 
Search instead for 
Did you mean: 
Create Post
Level 12

LastSystemUpTimePollUTC not updating for WMI node

I have a custom query that lists devices that are not currently polling by SNMP or WMI for statistics. The query uses the LastSystemUpTimePollUTC timestamp from the NodesStatistics table. However, a spot check reveals a few devices that will successfully poll for WMI. I look in the database for that node and can see that the value for the LastSystemUpTimePollUTC is indeed about 3 months old. How is this happening? Why is the value not updating? Thoughts?

0 Kudos
8 Replies
Level 8

Even I face the same issue. anyone resolved it yet?

0 Kudos

Hi @solar_vijay,

Does my below suggestion work for you?

0 Kudos
Level 12

Anyone?

0 Kudos

Hi @patriot,

For the nodes which show the old LastSystemUpTimePollUTC, if you manually initiate a poll or rediscover, will the LastSystemUpTimePollUTC change?

0 Kudos

The timestamp in the database does not update.

0 Kudos

My first instinct is that WMI is not functioning on the target node (or there's something blocking the path).  I would test from far end to local.

 

The easiest test to do would be this one: https://support.solarwinds.com/SuccessCenter/s/article/Testing-WMI-Connectivity.

For good measure, I tried the same on the machine I ran the test from.  In order for it to work locally you must leave the username, password, and authority fields blank.  If you can enumerate the classes, WMI is working.  Try the test then from your polling engine.  If it works locally, but not from the poller, I would then suspect that there is a network related issue (firewall, network config for WMI on the target node, etc.).

EDIT (2020-10-19):

You can also specifically check that the System Uptime is responding in WMI via: https://support.solarwinds.com/SuccessCenter/s/article/Check-the-LastBootUpTime-WMI-on-the-target-se...

If:

  • WMI is configured correctly
  • No network block (firewall, etc)
  • And when you test WMI you don't get a response of system uptime

...this may mean that the system performance counters are not working.  You can reset the counters by running the below command on the effected system:

 

lodctr /r
0 Kudos

1. wmi works on the local
2. wmi works from the poller
3. lastboottime matches on local and solarwinds web console
4. Assigned App monitors (service) are working fine.

Though the above checks are fine but LastSystemUpTimePollUTC  DOESNT update properly.

Please assist.

0 Kudos

Hi @solar_vijay,

If Orion is using the same credential that you used in your test (can't hurt to verify by Manage Nodes > Edit Properties > click TEST button in polling method section), then I would recommend contacting SolarWinds customer support.  I'm not sure what to do at that point.  Sorry.

0 Kudos