Showing results for 
Search instead for 
Did you mean: 
Create Post

Is WorldMap View broken?!?

Is anyone else having this issue when viewing Worldwide map?  Seems like MapQuest pulled the plug. 

The error takes you to this link. Modernization of MapQuest results in changes to direct tile access | MapQuest Dev Blog

Any help or info would be great.  We use this heavily on all our NOC views.


Labels (1)
179 Replies

The Config Wizard takes a long time to complete for us... close to 45 minutes on the core and about 15 minutes per polling engine. Besides, I had to put the SolarWinds services in Manual mode since they'd restart themselves during the Config Wizard.  That was causing a lot of problems, especially with services being uninstalled by the Config Wizard but not re-installed.  I don't know if someone else has a better workaround but that worked for us.

Anyway, that's my two cents.. 

0 Kudos

<-- One happy network guy. The hotfix indeed worked, but the installation time for me was bit longer than expected. Still, it worked so no complaints.

Thank you Shuth and mr.e for your inputs.

Hi delacres​. I installed the hot fix this afternoon. The hot fix itself installed fairly quickly (a minute) however it runs the Configuration Wizard afterwards to finish the installation process. Depending on how many modules you have installed and whether you let it run through the Optimise Website step, etc. this could be 15-30 mins.

Thank you, the Hot Fix appears to have fixed the map issue for me.  Had to re-adjust the default location and zoom since this map appears to be a bit different is scale, but spot checking on pin locations is initially showing these did not change.

0 Kudos


Thanks for the quick turn around on this.  Question, is there plans to release a hotfix for anyone NOT on NPM 12?  At a minimum at least 11.5.X users?

Yes. A hotfix for NPM 11.5 is in the works. It should be available sometime next week.

Hi aLTeReGo

Just for the sake of my curiosity - how did you workaround the actual root cause with free APIs? I am assuming all instances now use generic API key which is being sponsored by SolarWinds - just my guess - is this correct?

Thwack Home Page | Personal Blog
0 Kudos

When we introduced the world map feature in 2013, we leveraged a free service from MapQuest that included map tiles and geocoding based on the OpenStreetMap data. At this time, no API key was required for this service. We contacted MapQuest to confirm our understanding of their terms of service: that the Orion world map use case was within the bounds of uses they intended for this free service.

In December 2015, MapQuest informed us that their geocoding service would no longer be supported for commercial use without a paid API key. We paid for an API key (based on our projected usage for the next 12 months) and shipped NPM 11.5.3 with a code change to the world map feature that sent this API key with geocoding requests. Tiles were still free and unauthenticated.

Last week MapQuest discontinued the OpenStreetMap services entirely. The hotfix we shipped for NPM 12 last week changes the source of the tiles according to MapQuest's instructions (Modernization of MapQuest results in changes to direct tile access | MapQuest Dev Blog)​. This tile usage is now charged to the SolarWinds API key, just as geocoding has been since NPM 11.5.3. You'll notice the tiles look different as well, since they are now coming from an entirely different MapQuest service.

much appreciate for such detailed reply - thanks a lot - all clear now

Thwack Home Page | Personal Blog
0 Kudos

With regard to the tiles coming from a different service - where would we find the FQDNs for that service?  Our small government entity has severe firewall restrictions due to worries from the usual suspects...

0 Kudos

Orion loads the MapQuest plugin for Leaflet from Currently I have observed this plugin contacting {a,b,c,d} and, but this is controlled by MapQuest and not by SolarWinds, so it may change without notice.

Much obliged!

0 Kudos

Thanks Jeff!

Level 9

support case opened here as well.

0 Kudos

It's broken for me -- I just noticed today. Support case opened, will update this thread as it progresses...

Hopefully it can be fixed easily, or at least a workaround.

0 Kudos
Level 9

looking in c:\inetpub\SolarWinds\Orion\js\WorldMap.js\

I am able to update the code to use a valid key, and also use the new api key and leaflet.js as per this instruction set MapQuest Developer Network | Documentation

But as yet still no beans making it work. But if somebody with a greater mind then mine can take a look this may be useful.

"This documentation assumes that you have basic knowledge of Leaflet."

Well. I'm out. LOL.

Today class, we'll be experimenting with Javascript, usage of the Leaflet Javascript Library, and API Key usage.

Level 9

I just spoke to support, it seems like there support are pointing people at this Worldwide Map is not automatically placing some or all nodes on the map via geolocation - SolarWinds...

do not do this, its to do with Geo Location. The problem is source images for the maps (tiles)

Support do not have a formal answer as to where to put the API key so hold fire.

I noticed the support link was broken. Here is the article you should reference from support: There is a fix now available for 12.0 and one is in the works for 11.5.3. If you have a version older than 11.5.3, you will need to upgrade.

0 Kudos

Curious about this statement: "If you have a version older than 11.5.3, you will need to upgrade".

Does this mean there's no plan for making an official hotfix available for "Orion Platform 2014.2.1" e.g. 11.0.x, even if that fix may take awhile to create?

Edit: I hope I'm not the last person on Earth to still be running 11.0.x .  I'm planning to upgrade by the end of this year to 11.5.x. I'm just one of those upgrade procrastinators.

0 Kudos

Is it just me or is this page gone?