cancel
Showing results for 
Search instead for 
Did you mean: 
Create Post
Level 7

Help with Unknown device

Hello

I am currently trialling Orion NPM. When using the network discovery tool, all of my Windows 2003 Servers are listed as 'unknown' and i get very little info from them.  After looking up the issue here, I had deleted the node and attempted to add it manually. SNMP tests okay in the first stage but when i reach the 'change properties' stage i get the following error message:

 

System.NullReferenceException: Object reference not set to an instance of an object.
at SolarWinds.NPM.Common.CustomPropertyMgr.GetCustomProp(String tableName, String propName, Int32 objectID) in C:\Source\OrionNPM\DEV\Release\Orion\Core\9.1\Src\Lib\SolarWinds.NPM.Common\CustomPropertyMgr.cs:line 115
at SolarWinds.Orion.Web.CustomPropertyManager.GetCustomProp(String tableName, String propName, Int32 objectID) in C:\Source\OrionNPM\DEV\Release\Orion\Core\9.1\OrionCommon\OrionWebAssembly\CustomPropertyManager.cs:line 42
at Orion_Nodes_Controls_CustomProperties.repCustomProperties_ItemDataBound(Object sender, RepeaterItemEventArgs e)
at System.Web.UI.WebControls.Repeater.OnItemDataBound(RepeaterItemEventArgs e)
at System.Web.UI.WebControls.Repeater.CreateItem(Int32 itemIndex, ListItemType itemType, Boolean dataBind, Object dataItem)
at System.Web.UI.WebControls.Repeater.CreateControlHierarchy(Boolean useDataSource)
at System.Web.UI.WebControls.Repeater.OnDataBinding(EventArgs e)
at System.Web.UI.WebControls.Repeater.DataBind()
at Orion_Nodes_Controls_CustomProperties.LoadCustomProperties()
at Orion_Nodes_Controls_CustomProperties.Page_Load(Object sender, EventArgs e)
at System.Web.Util.CalliHelper.EventArgFunctionCaller(IntPtr fp, Object o, Object t, EventArgs e)
at System.Web.Util.CalliEventHandlerDelegateProxy.Callback(Object sender, EventArgs e)
at System.Web.UI.Control.OnLoad(EventArgs e)
at System.Web.UI.Control.LoadRecursive()
at System.Web.UI.Control.LoadRecursive()
at System.Web.UI.Control.LoadRecursive()
at System.Web.UI.Control.LoadRecursive()
at System.Web.UI.Control.LoadRecursive()
at System.Web.UI.Control.LoadRecursive()
at System.Web.UI.Control.LoadRecursive()
at System.Web.UI.Control.LoadRecursive()
at System.Web.UI.Control.LoadRecursive()
at System.Web.UI.Control.LoadRecursive()

at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

Can anyone help me find what i'm doing wrong here? So far i like this product very much and hope i can resolve these issues.
0 Kudos
3 Replies
Level 13

puggsley,

Please open a support ticket, and select the Eval version of NPM. Someone will get back to you shortly to help you sort out your issue.

0 Kudos
Level 7

Hi,

The issue seems to have resolved itself, manually adding the devices now works okay.

thanks for the help

0 Kudos
Level 13

Great! Glad it's working for you now.

0 Kudos