cancel
Showing results for 
Search instead for 
Did you mean: 
Create Post
Level 7

HTTP POST ACTION fails to execute. Any ideas?

Hi all,

I'm trying to get solarwinds to send alert information to the slack api and solarwinds is being stubborn. I have setup the integration and have a working url that put in the action on solarwinds but I get the error "failed to execute http request" when I trigger it. I can't find any details on why it fails and I know the url is good. Any ideas?

Labels (2)
0 Kudos
8 Replies
Level 8

I also hade issues with this. When implementing both an alert and reset action, i tested the payload text gradually until i was satisfied with the result. All worked OK, both alert and reset actions posted to our Slack channel.

After a while i noticed only reset messages showing up on our slack channel. After a bit of detective work i noticed one difference between alert and reset payloads, only the Alert payload had the ${N=Alerting;M=AlertMessage} variable.

My alert message contained: Node "${N=SwisEntity;M=Caption}" is ${N=SwisEntity;M=Status;F=Status}

After i removed the quotation marks in the Alert Message, it all started to work again.

I know i edited the alert message after completing alert and reset actions, must have slipped my fingers and put in quotation marks there.

0 Kudos

Hi  @guran84 how are you? sorry can I ask you how did you complete the field body of the post? I complete it in this way but nothing comes to me: /

Body to POST

{

         ${N=SwisEntity;M=ApplicationAlert.ApplicationName}

         ${N=SwisEntity;M=Node.DisplayName}

         ${N=Generic;M=DateTime;F=DateTime}

         ${N=SwisEntity;M=Status}

        }

Thank you

0 Kudos
Level 8

geops, in the body of POST make sure there aren't any spaces.  I was having the same issue yesterday when trying to configure the action: Send a POST Request using HTTP POST.  If you have now spaces in the text in the body of the POST your test of the trigger should work.

0 Kudos
Level 11

Try recreating the "failed to execute http request" issue when you trigger it.

But before doing that, have a packet capture software ready.

Also, try using Log Adjuster on your Primary SolarWinds polling engine and set both the

"ACTIONS EXECUTION"

and

"ACTIONS EXECUTION for ALERTING"

to ALL, and hit APPLY.

Then, run the packet capture, recreate the error, stop the capture, and go back to Log Adjuster to reset it back to defaults.

The packet capture approach may help in narrowing down how the communication is taking place.

The "Show ALL actions execution for alerting" Log Adjuster approach may help in pin pointing what exactly is happening.

Hope this helps.

Hi geops​,

Did you ever manage to find a reason or a solution to this problem? I am trying to integrate my solarwinds with OpsGenie, and sadly it is giving the same error.

Thanks in advance!!

Abdhija Sharma

0 Kudos

Hi,

were you able to get any resolution to integrate Opsgenie ?

0 Kudos
MVP
MVP

Have any restrictive group policies that would prevent this?  Any HIPS obstacles?

0 Kudos

I couldn't find anything that would block outgoing HTTP requests.

0 Kudos