cancel
Showing results for 
Search instead for 
Did you mean: 
Create Post
Level 9

Configuration Wizard error "No valid package combination was found for current system"

Jump to solution

Running Versions:

Orion Platform 2016.2.100

NPM 12.0.1

SAM 6.3.0

NCM 7.5

NTA 4.2.0

IPAM 4.3.2

Configuration wizard will not complete due to the error "no valid package combination was found for current system" on 1 of 7 APE's.

The only info on resolving the issue points to PackageCleaner.exe which is contained in Orion Platform 2017, I'm not prepared to upgrade the total infrastructure at this time.

I have uninstalled all software from the APE and reinstalled and the error continues what am I missing has anybody run into this and have a resolution? I do have a support case started 1181939 the initial response was use the PackageCleaner.

Any thoughts or idea's would be greatly appreciated.

Thanks Tom

Labels (1)
1 Solution
Level 9

I was able to resolve my issue by comparing the c:\Program Files (x86)\SolarWinds\Orion\Packaging\Repository

with one of my other APE files there was one opkg file different copied to the APE having the issue and the configuration wizard completes and all services are working again on the APE.......

Thanks for the suggestions and help!

View solution in original post

19 Replies
Level 8

I had this issue when upgrading my APE to (2019.2) NPM12.5. I never found the packagecleaner.exe so I ended up renaming my Repository folder to repository.old and copied the folder over from my primary server. Ran the configuration wizard again and it completed successfully. ( C\:\Program Files (x86)\SolarWinds\Orion\Packaging\Repository.old)

Level 8

I also received this error on a brand new install WITHOUT NTA.

0 Kudos
Product Manager
Product Manager

Did you run into this again with upgrades past 12.0.1 ?

0 Kudos

Serena,

As mentioned in my post above, I ran into this issue installing a new poller in an NPM 12.1 environment. I just completed another new poller installation to same 12.1 environment. THe difference was this time, I stopped the config wizard after the scalability installer ran, then applied all the necesary hotfixes (in proper order), cancelling the config wizard until I ran the last hotfix. Then I ran the config wizard and did not experience this issue.

Thanks

Marc

0 Kudos

Thanks for the detailed explanation. Do you plan on upgrading to 12.2 at any point? We have updated our hotfix process to be more streamlined, so I'd be curious to get your opinion on whether the change is positive.

0 Kudos

I do plan to upgrade to NPM 12.2. But I am waiting for next round of fixes for IPAM 4.6 to get posted. Here is that thread: IPAM 4.6 is broken .

It looks like IPAM 4.6 HF2 is published today. I look forward to seeing your feedback.

0 Kudos
Level 12

On the additional poller, which copies from the primary, so the primary is up and running and everything working.

0 Kudos
Level 9

I was able to resolve my issue by comparing the c:\Program Files (x86)\SolarWinds\Orion\Packaging\Repository

with one of my other APE files there was one opkg file different copied to the APE having the issue and the configuration wizard completes and all services are working again on the APE.......

Thanks for the suggestions and help!

View solution in original post

Had the same issue as you, the guys from support was looking at it and thats what they was looking at, one package being a different version. I've been told to use the installer on the additional pollers because it basically sucks the same config from the primary poller. So well done

0 Kudos
Level 12

I just installed 12.1 with HF3, which is supposed to include HF 2 and 3, but I still get the error trying to install an APE and an AWS.

0 Kudos

I just finished installing Platform 2017 HF3 on the PPE and then attempting to install the APE using the "Download" option from the Polling Engines page. Still get the error.

The goofy thing is, the ReadMe for HF3 says that it should be installed on the APE as well, but you can't do that since SolarWinds has not yet been installed there!!

What the.....?

0 Kudos

On 12.1 the recommended fix is as follows........

Please try the following to resolve.

  

  1. Locate the PackagesCleaner.exe.config file. By default, this is located in c:\Program Files (x86)\SolarWinds\Orion.
  2. Edit the file and change <add key="RunCleaner" value="true"/> to
    <add key="RunCleaner" value="false"/>.
  3. Copy all opkg files from c:\Program Files (x86)\SolarWinds\Orion\Packaging\Repository.Backup
    to c:\Program Files (x86)\SolarWinds\Orion\Packaging\Repository.
  4. Run the configuration wizard.

Is this done on the APE or the Primary poller?

0 Kudos

I am on 12.1 HF1, Orion 2017 HF3, and this suggestion worked on a poller also. Disabled the cleaner, copied the files (from the backup repo in my case), and ran config wizard.  I was using the scalability installer to actually install everything on a new poller.  Thanks for posting this solution!

0 Kudos

Disabling the packages cleaner and copying packages from the main polling engine worked for me. Thanks for the clue. I'm on 12.1 HF1.

0 Kudos

My feeling is that the issue is with NTA but without seeing the logs it's tough.

Installer does not launch during an upgrade to NTA 4.2.2 - SolarWinds Worldwide, LLC. Help and Suppo...

0 Kudos
Level 16

Are you on NPM 12.1 as the hot fix addresses that issue.

  • Upgrade to NPM 12.1 with NTA 4.2.1 fails with the following error: No valid package combination was found for current system.

NPM 12.1 Hotfix 1 - SolarWinds Worldwide, LLC. Help and Support

0 Kudos

I'm on NPM 12.0.1........

0 Kudos