Showing results for 
Search instead for 
Did you mean: 
Create Post
Level 8

Centralized Upgrade Error

Hi Everyone,

I have a fairly large environment consisting of 25 APEs and 25 HA APEs. These APEs span across different datacenters across the globe. When attempting to do the centralized upgrade to 2019.4 I am running into an issue on several of the APEs.

The APEs will first state "Downloading installers...2%" along with the KB/s of which it is downloading. But that's where they stop. After several minutes they will fail out with the following error.

An error was encountered while downloading updates:

Can't download file, because of the invalid checksum: 38385A81664CE562A6777FA4564AE7B93F38F1224E1206550136E2B6B5DBB9DD for file C:\ProgramData\SolarWinds\Downloads\CORE-2019.4.5220.20161-CoreInstaller.msi


I've already tried to retry the download and the same thing happens.

So I remoted into one of the servers having the issue and pasted the URL from the error message;

and I were able to download it with no problem across the internet.

So on the problem APE I navigated to the file location displayed in the error message;


I deleted the file that was currently present and then clicked retry again on the web console. After a few minutes, the file appeared and even though the percentage on the web console stated 2% the file size was growing, slowly but the percentage never changed.


I also verified if I was able to navigate to my Primary Polling Engine from the troubled APE and I was able to with no issues.

All of the 14 APEs that completed the upgrade successfully were in fact located in the same Datacenter as my Primary Polling Engine. So I started checking the latency between the APE and Primary and yes some had some high latency but there were also several that were under 30ms and those also failed.

I am drawing a blank on this and any help would be great

Labels (2)
9 Replies
Level 9

Don't know if you're resolved the issue, but seeing this in our environment as well. Although this is with the Jan 9, 2020 HF.

0 Kudos
Level 13

My goodness, I pray for anyone with such large environments to upgrade.

0 Kudos
Level 10

Did you resolve this issue? I'm just now encountering the _exact_ same error message. Our polling engines are spread out all over the world. One or two for every continent.


(Except for the one with the "Communication error", but that one is in China so that was expected.)

0 Kudos

same setup and issue. how were you able to resolve this issue? thanks!

0 Kudos

When downloading the installer to the server directly and running it there, I get the following error.


0 Kudos

I am facing similar error while installation of APE



0 Kudos
Product Manager
Product Manager

jakegevans  It would be highly beneficial if you could create a support case and provide diagnostics along with your write up above.  Please share it here and we can take a look to see what is occurring. 

Support case 00421949 has been created

0 Kudos


did you ever get a resolution for this?

APE's over the WAN is not a solid product. We have struggled with the remote update since it launched with timeouts and very poor download rates. We don't have any latency or performance issues as it works fine when you copy via unc path. I have had multiple tickets since the feature launched but never a resolution and only workarounds. 

Soalrwinds just launch a new update and guess what - all the remote WAN APE's are failing again.

The long term work around is to copy the files manually form the Master and I am fed up of doing that. It puts me off expanding like you have.

APE's should only be deployed on the LAN where the Master is and perhaps look to VNQM and IPSLA to measure any field office or datacenter measurements. 



0 Kudos