cancel
Showing results for 
Search instead for 
Did you mean: 
Create Post
Level 9

Anyone used Riverbed WAN Opt Rpts from Community?


This is a nice report, but doesnt seem to work as the result shows negative optimization on the Riverbed Steelhead interfaces.  I looked at the SQL in the custom report and see that the contributor using IN_TotalBytes and IN_TotalPkts for POST interface results.  Shouldn't he be using IN_Totalxxx on the pre-opt (LAN) interface and OUT_Totalxxx on the post-opt (WAN) interface?  I tried this and the results are better- the % optimization is positive value, but a small number.  Is this all that needs to be fixed?  Anyone else fixed this, as I need to be sure I'm doing the right thing.

0 Kudos
3 Replies
Level 8

i'm working on a similar issue. I am trying to report on the Percentage bandwidth reduction over time. I found that the Agg on the LAN resets around 4GB. this is because the values are stored as counter32 which means the value is wrapped when it hits 32 bits (4294967295).

The only way I see of being able to do this is if there was a way to transform the figure based on the previous poll, for example the new figure would be (newValue-previousValue)+previousValue. essentially incrementing by the differnence in the value and stoppin git resetting to zero.

Personally I think that Riverbed should set the device so that if either the LAN or WAN wraps and resets to zero then they both should.

I note that this post is quite old so if anyone has since had success in doing similar to what i'm trying to achieve i'd appreciate it.

0 Kudos
Level 9

I am having an issue with these reports also. First of all, they don't appear to be reporting anything close to what the SH appliances are reporting as % optimization and, secondly, if I put anything more than the last 30 minutes the report hangs at "querying database" forever. If these reports are reporting accurate data then Riverbed is lying about their true optimization. I would really like to get these working and send a report to my supervisor every so often but I just don't know if they are that trustworthy yet.


These reports are killing me. We have been getting the negative data values also and I have had no luck finding a fix. I know very little about SQL and even less about making reprots in Orion at this point but have been searchign the forumes for a fix. I am finding many other people with the same issues but not a fix as of yet. Any help would be welcomed, if you are able to figure it out please post the results here so we can all benefit. I will do the same.

0 Kudos