cancel
Showing results for 
Search instead for 
Did you mean: 
Create Post
Level 8

Alerts - Percent variable being displayed as a variable


Some of my alerts display their received and transmit statistics in what appears to be an exponent.

It should be displayed as a percentage.

Any ideas on why and how to fix this?

Hee is an example:

Alert: Transmit Percent Utilization of

DEVICEX is 3.

Current traffic load of this interface is

       Received :3.979446E+07

       Transmitted :284929.2

0 Kudos
5 Replies
Level 8

I talked with a technical support rep and found a solution.

Change the following variables:

${InBps} to ${InBps as bandwidth}

${OutBps} to ${OutBps as bandwidth}

In summary, the message looks like this:

ALERT: Transmit Percent Utilization of ${FullName} is ${OutPercentUtil} %.

Current traffic load of this interface is

     Received : ${Inbps as Bandwidth}

     Transmitted : ${Outbps as Bandwidth}

So now instead of getting a "Receive" or "Transmitted" result in scientific notation such as "979446E+07", you should get "18 M".

Hope this helps.

0 Kudos
Level 7

I have the same issue. I'm a NPM n00b so any pointers would be appreciated. Default variables are being used. Link is a DS3.

active alert.JPG

0 Kudos

Is this using the Basic Alert Manager, or Advanced Alert Manger?  The screen shot looks like Basic, if so this is displaying the following variables:

Alert: Transmit Percent Utilization of ${FullName} is ${OutPercentUtil}.

Current traffic load of this interface is

     Received : ${InBps}

     Transmitted : ${OutBps}

So output percentage on the first line, with actually traffic (in and out) bps on the bottom.

I'd suggest moving to Advanced alerts to make this a little more customisable.

Stuart

0 Kudos
Level 17

What variables are you using here? That looks like packets-per-second. Likely you want ${InPercentUtil} and ${OutPercentUtil}

0 Kudos

Let me further clarify.

Below is an example of how the alert is configured which I believe is the default settings.

Also below is the email that I receive based upon those settings.

As you can see my received traffic is: 3.979446E+07

What exactly does that mean?  How do I correct that?

Here is an example of my "High Transmit Percent Utilization" configuration

     Subject:      Alert: High transmit percent utilization on ${FullName}

     Message:   Alert: Transmit Percent Utilization of ${FullName} is ${OutPercentUtil}.

                       Current traffic load of this interface is  Received : ${InBps}

                                                                                   Transmitted : ${OutBps}

Here is an example of the email I receive:

Alert: Transmit Percent Utilization of switch is 3.

  Current traffic load of this interface is

     Received : 3.979446E+07

     Transmitted : 284929.2

0 Kudos