cancel
Showing results for 
Search instead for 
Did you mean: 
Create Post
Level 8

APC UPS Monitoring with ORION PLATFORM 2018.2

Jump to solution

Hi Everyone,

With the release of 2018.2, APC UPS monitoring is now natively supported. I have been trying to figure out why some of my APC UPS units are reporting correctly, and others are not. I am referring to the Power Control Unit Status section of node details, SNMP is functioning but returned unknown status' for a few fields. While the other fields work as expected. Based on my environment, I have been able to limit the problem to SMARTUPS2 devices (aka UPS Network Management Card 2). Where my other older UPS units, like Smart-UPS 3000 RM XL, work without issue. In the example below, I provided one working and one not working node. The battery does not need replacement on this particular node, but returns wrong.

SMARTUPS2

UPS STATUSUnknown
BATTERY STATUSUnknown
NAME APC UPS
SERIAL NUMBER AS1628264973
MODEL Smart-UPS X 3000
LAST FAIL CAUSE Self Test
BATTERY PACK COUNT 0
OUTPUT LOAD 0 %
BATTERY CAPACITY 0 %
BATTERY TEMPERATURE 32 °F
TIME ON BATTERY 0
RUN TIME REMAINING 0
REPLACE INDICATOR Battery Needs Replacement

Smart-UPS 3000 RM XL

UPS STATUSOn Line
BATTERY STATUSNormal
NAME {removed}
SERIAL NUMBER JS0801002212
MODEL Smart-UPS 3000 RM XL
LAST FAIL CAUSE Self Test
BATTERY PACK COUNT 0
OUTPUT LOAD 0 %
BATTERY CAPACITY 100 %
BATTERY TEMPERATURE 64.4 °F
TIME ON BATTERY 0
RUN TIME REMAINING 4h:28m:00s
REPLACE INDICATOR Battery Doesn't Need Replacement

Any information or recommendations are appreciated.

Labels (1)
1 Solution

2018.2 HF2 has solved the issue in my original post thankfully.

View solution in original post

14 Replies
Level 7

Hi again Matt,

I am seeing this pop up again, this time with newer devices. Brand new Smart-UPS 5000's are polling correctly but not filling up the custom Solarwinds widgets properly. Has there been any fix for this yet?

0 Kudos

I still cant rely on any of the information in the widget. Even after deleting a node completely and re-adding it, I still see information for the old node

Are you still having problems?

0 Kudos

I just started adding some more APCs that were missed last fall (October) and they are all successfully polling VIA SNMP but they are showing an unknown status in the widgets.  Any ideas why that would be?  We are on NPM 12.3 and Orion 2018.2 HF6 and have been on that version since upgrading in March 2019.

0 Kudos
Level 7

Do you mean HF1? Though it was released the day after you posted... I dont see HF2 for 2018.02

0 Kudos

2018.2 Hotfix 2 was released June 28th, Hotfix 3 came out July 4th.

Orion Platform 2018.2 Hotfix 2 - SolarWinds Worldwide, LLC. Help and Support

I see. I was confused by the date on the full online install vs just the hotfix. I will install and update on this thread, thanks for the help.

0 Kudos

Installed July 4 2018.02HF3, does indeed fix issue. Thanks!

0 Kudos
Level 7

Hi there,

I am also interested in this. I have 80 or so UPSes, and have noticed the following-

Ruled out NMC as cause- I have the Power Control Unit Status working for AP9617, AP9619, AP9630, and AP9631 on SUA 1500/2200/5000.

Common thread appears to be that all my SUA have the PCUS widget working regardless of NMC, and none of my SMT work (but do poll fine as OP has stated).

All firmware OIDs look like this-

SUA, which are older, all have version that look like "657.19.M" or similar

SMT, which are newer line, all have version that look like "UPS 09.2 (ID18)" or similar.

After having dug into this quite a bit, I have ruled out APC as the cause of this. The support engineer I spoke to insisted that none of the MIBs in this year's update changed, they only added new MIBs. Also, the single widget itself is not an issue, I have create a custom database in Solarwinds which pulls/fails to pull the same data as the widget (Orion Object = UPS, UPS on Node > UPS Statistics).

So, something in the code itself is pulling data successfully for SUA but not for SRT.

Also, that widget has some issues where for instance it was successfully populated, but I updated the node to a different UPS but the old information stuck (because the new device was an SRT and thus was not able to update the widget). I have also seen temperatures which were old (compared to a custom wiedget which just outputs the MIBs and was updating successfully). Thus, I would not be to sure any of the information is updating successfully for SRT series...

0 Kudos
Level 9

Where is that view?  I'm on 2018.2 HF2 and don't get any of that information. I also don't see a widget to add or a pre-defined view to assign it to?  I would love to use this functionality.

0 Kudos

That view is within your node details, If you do not see Power Control Unit Status section - ensure you have enable the UPS option enabled under that nodes resources, as shown below.

pastedImage_0.png

Orion Platform 2018.2 Improvements - Chapter One

Thanks.  It wasn't in Node details, but I've customized that view.  All I had to do was add the Power Control Unit Status widget, and it was good.  I appreciate the help.

0 Kudos
Level 14

Add one more interested user on this one. I am seeing the same thing. Is this a case for the UnDP tool, or is there a glitch at work here?

I raised a ticket with the SolarWinds support team, and apparently some APC UPS firmware versions do not have the OID for Battery Pack Count, and has been marked as a bug.

From Support:

"I consulted this to DEV and the reason why it shows unknown for SMARTUPS2 device as it does not have "Battery Pack Count" property - 1.3.6.1.4.1.318.1.1.1.2.2.5 - an OID that Orion expects each UPS Node to have. This has been tag as a bug on this current version.
Unfortunately, there is no workaround at the moment; the good news is the fix is done and approved for upcoming Orion HotFix2 but not ETA yet."

0 Kudos

2018.2 HF2 has solved the issue in my original post thankfully.

View solution in original post