cancel
Showing results for 
Search instead for 
Did you mean: 
Create Post
Level 14

Deadlock Error in Logs

This morning I ran some of my NCM jobs and noticed this error in the logs. (DEVICE) was deadlocked on lock resources with another process and has been chosen as the deadlock victim. Rerun the transaction. Any ideas?

0 Kudos
4 Replies

We continue the discussion about this issue here NCM job showing error in output log

0 Kudos
Level 12

Normally this occurs when there are two process that are trying to modify the same data. An example would be running a maintenance job and also running the config backup. What types of jobs did you have running prior?

0 Kudos

The errors occurred before the maintenance period.  I'm running them manually now and am getting the same error. Maintenance isn't running. I've even dropped simultaneous downloads/uploads to 5 to try to stop the errors, but they are still occurring.

0 Kudos

Ah okay, then I would suggest sending this through support. We can go through the logs in greater detail and evaluate the setup to see what is causing this to trigger.