cancel
Showing results for 
Search instead for 
Did you mean: 
Create Post
Level 8

Connection refused during Cisco config download

Jump to solution

I am using NCM7.2.2 to download a cisco switch config from the web console.  When I go try to download it, I get the message that the connection was refused the by the switch IP address.  I have tried to rediscover the node using the SNMPv3 credentials again.  I am however, able to download the configs from Engineers toolset, just not the webconsole.

I enabled Session tracing and this is the error that I'm getting:

[3/6/2014 7:22:01 PM] UseCustomMorePromptBehaviour: False

[3/6/2014 7:22:01 PM] MorePromptKey: 

[3/6/2014 7:22:01 PM] Login Attempts: 1

[3/6/2014 7:22:01 PM] Custom UserName Prompt:

[3/6/2014 7:22:01 PM] Device Template: Cisco IOS-1.3.6.1.4.1.9.ConfigMgmt-Commands

[3/6/2014 7:22:01 PM] System Name: 01csw2.rc.era.nara.us

[3/6/2014 7:22:01 PM] System Description: Cisco IOS Software, C3750 Software (C3750-IPBASEK9-M), Version 15.0(2)SE, RELEASE SOFTWARE (fc1)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2012 by Cisco Systems, Inc.

Compiled Sat 28-Jul-12 00:16 by prod_rel_team

[3/6/2014 7:22:01 PM] System OID: 1.3.6.1.4.1.9.1.516

[3/6/2014 7:22:01 PM] OS Image: C3750-IPBASEK9-M

[3/6/2014 7:22:01 PM] OS Version: 15.0(2)SE, RELEASE SOFTWARE (fc1)

[3/6/2014 7:22:01 PM] Menu-Based mode=False

[3/6/2014 7:22:01 PM] FreezeLoginForPreCommands mode= False

[3/6/2014 7:22:01 PM] FISP mode= False

[3/6/2014 7:22:01 PM]

-->StateChange: Connecting to server<--

[3/6/2014 7:22:02 PM] Solarwinds.Net SWTelnet9 Version 9.0.27

[3/6/2014 7:22:02 PM] Connected! The requested connection has been refused by the remote host.

[3/6/2014 7:22:02 PM]

-->StateChange: Disconnected from server<--

[3/6/2014 7:22:02 PM] Disconnected - From: [Switch IP Address]

Tags (3)
0 Kudos
1 Solution
Level 10

It looks like you are trying to download your configs with the login credentials and not SNMP.  It looks like youe default login is trying to use Telnet to log in.  Either change it to SSH if you block telnet or change the request Configs Using to reflect SNMP.  Edit the properties and under NCM properties you will see something like this:

Edit Page.png

Select the dropdown for Request Configs Using and Select SNMP (or SSH1 of SSH2):

Request SNMP.png

If you select SSH the Transfer Configs using will automagicly change to TFTP:

Complete Change.png

You can change the Global Settings here:

Where to change.png

View solution in original post

0 Kudos
4 Replies
Level 10

It looks like you are trying to download your configs with the login credentials and not SNMP.  It looks like youe default login is trying to use Telnet to log in.  Either change it to SSH if you block telnet or change the request Configs Using to reflect SNMP.  Edit the properties and under NCM properties you will see something like this:

Edit Page.png

Select the dropdown for Request Configs Using and Select SNMP (or SSH1 of SSH2):

Request SNMP.png

If you select SSH the Transfer Configs using will automagicly change to TFTP:

Complete Change.png

You can change the Global Settings here:

Where to change.png

View solution in original post

0 Kudos

That worked, thank you so much!

0 Kudos
Level 18

Hi 1ashgarg,

Have you configured the device in NCM to use the same protocol (telnet/SSH) and port as in Engineering toolset?

Regards,

Jiri

0 Kudos

The NCM devices were discovered using SNMPv3, and Engineering toolset also used SNMPv3.  Do I need to change the device information?

0 Kudos