cancel
Showing results for 
Search instead for 
Did you mean: 
Create Post
Level 10

Cisco 4507 unable to login using NCM

Jump to solution

Dear Team,

I am having around 250 Cisco 4507 Devices. I am unable to login using NCM to the devices, where as i could login using Putty. ALso i have did a session trace. The output is as below:

[17298157] [09/09/2019 09:48:53.104] -----------------Net. SWTelnet v7.10.0.166-------------------

[17298157] [09/09/2019 09:48:53.120] UseCustomMorePromptBehaviour: False

[17298157] [09/09/2019 09:48:53.135] MorePromptKey:

[17298157] [09/09/2019 09:48:53.135] Custom MorePrompt Pattern:

[17298157] [09/09/2019 09:48:53.151] Login Attempts: 1

[17298157] [09/09/2019 09:48:53.167] Enable Identifier: #$

[17298157] [09/09/2019 09:48:53.182] Device Template: Cisco IOS Connection Profile: AUH

[17298157] [09/09/2019 09:48:53.182] UseExactPromptMatch=False

[17298157] [09/09/2019 09:48:53.198] Menu-based mode=False

[17298157] [09/09/2019 09:48:53.213] FreezeLoginForPreCommands mode= False

[17298157] [09/09/2019 09:48:53.213] CommandCharKey = Default

[17298157] [09/09/2019 09:48:53.229] FISP mode= False

[17298157] [09/09/2019 09:48:53.229] EncryptionAlgorithm= Auto

[17298157] [09/09/2019 09:48:53.229] WODSSH Version: 2.7.2.180

[17298157] [09/09/2019 09:48:53.245] UseVirtualPromptForCommands False

[17298157] [09/09/2019 09:48:53.245] Responce Timeout in seconds: 15

[17298157] [09/09/2019 09:48:53.260] Connection Timeout in seconds: 45

[17298157] [09/09/2019 09:48:53.260] StateChange: Connecting

[17298157] [09/09/2019 09:48:53.510] Got HostFingerPrint: System.Byte[]

[17298157] [09/09/2019 09:48:53.573] SWTelnet9 Crypto Information Begin

[17298157] [09/09/2019 09:48:53.573] Protocol = SSH2

[17298157] [09/09/2019 09:48:53.588] RemoteName = 10.107.158.1

[17298157] [09/09/2019 09:48:53.604] SCcipher = aes128-cbc

[17298157] [09/09/2019 09:48:53.604] CSCipher = aes128-cbc

[17298157] [09/09/2019 09:48:53.620] Keys = ssh-rsa

[17298157] [09/09/2019 09:48:53.635] SWTelnet9 Crypto Information End

[17298157] [09/09/2019 09:48:55.292] TimerTick: mstrData=<> State=Connecting

[17298157] [09/09/2019 09:48:55.292] Pending Disconnect = False

[17298157] [09/09/2019 09:48:55.307] TimerTick: not idle, leaving

[17298157] [09/09/2019 09:48:56.198] Got Login Challenge: Password:

[17298157] [09/09/2019 09:48:56.198] Keyboard Interactive Authentication not set. Stop processing login challenge

[17298157] [09/09/2019 09:48:57.323] TimerTick: mstrData=<> State=Connecting

[17298157] [09/09/2019 09:48:57.323] Pending Disconnect = False

[17298157] [09/09/2019 09:48:57.338] TimerTick: not idle, leaving

[17298157] [09/09/2019 09:48:58.260] StateChange: Disconnected

[17298157] [09/09/2019 09:48:58.260] TimerTick: Killing session timer.

[17298157] [09/09/2019 09:48:58.276] Connection Error : WeOnlyDo.Exceptions.SSH.AuthorizationException: Authentication with the server failed.

at A.B.E(Int32 )

at A.B.d(Int32 )

at A.B.A(IAsyncResult , Int32 )

[17298157] [09/09/2019 09:48:58.292] TimerTick: Killing session timer

The Model details are as below:

Cisco IOS Software, Catalyst 4500 L3 Switch Software (cat4500e-I​PBASEK9-M), Version 12.2(53)SG​4, RELEASE SOFTWARE (fc2) Technical Support: http://www.c​isco.com/t​echsupport Copyright (c) 1986-2011 by Cisco Systems, Inc. Compiled Fri 25-Feb-11 15:22 .

Any body has any such experiences. One Doubt i am feeling is that Node is having an SSH Authenticaltion with Diffie Helman Group 1 SHA Authentication. Will it be an issue. What is the work around.

Best Regards,

Geo John

0 Kudos
1 Solution
Level 10

Hi,

I cleared it off. Its because of some issues in the Credential Parameters. Now  we are using plan text without any special characters and it worked.... We are using normal Cisco IOS Template.

Thank you

View solution in original post

0 Kudos
2 Replies

In the node properties, does it pass the NCM test? If not, you'll need to check them.

But the Cisco 4507 normally just work fine with SSH. Please post up your NCM profile for one of these nodes.

0 Kudos
Level 10

Hi,

I cleared it off. Its because of some issues in the Credential Parameters. Now  we are using plan text without any special characters and it worked.... We are using normal Cisco IOS Template.

Thank you

View solution in original post

0 Kudos