cancel
Showing results for 
Search instead for 
Did you mean: 
Create Post
Level 7

Additional 'enable level' option in a Connection Profile NCM

Hi all and thanks in advance for any help,

I hope I'm not asking something terribly obvious. I have just created a new Device Template for a device and wanted to create a connection template too; all looks fairly obvious but I have a problem with the 'enable level' field. I can only choose between 'enable' and 'no enable login'... However, the device I want to add uses 'config' to elevate privileges. How do I add another option (config) to that drop-down menu? If I go with 'enable' the device throws a syntax error, so I know that if I could replace the 'enable' word, all would be good.

Thank you, Tim  

connection profile.PNG

Labels (2)
0 Kudos
11 Replies

There is an option in the device template where you specify the enable command. In here you just specify if you need some command to issue before taking the config or if you just issue a command right after logging in to get the config.

i hope I am not too confusing here

Level 7

Hi HerrDoktor,

okay, so as long as I have this:
<Command Name="EnterConfigMode" Value="config"/>and select 'enable' in the connection profile, I should be good? The password used for 'config' then goes under the connection profile's 'enable password' box?

Thanks, Tim


0 Kudos

Yes from your description of your process, that should do the trick.

0 Kudos
Level 7

Hi HerrDoktor,

thank you for your help, I'm sorry I was not able to update sooner; I was quite busy and did not have the time to finish testing this. I have had another go at it today and and just could not get it to work with scripts. NCM logs into the device alright, but does not seem to execute commands at all.

Firstly this is the manual process we want executing:

1. Login

2. Go to 'config' mode: conf -> requires password

3. Execute commands with scripts.

I think the issue lies in the fact that there is nowhere to put the 'conf' level password in. If I try that through 'enable' in the Connection Profile, it fails as the device does not recognise the command 'enable'. I tried putting an XML line down to point enable to conf, but that did not work.

It seems okay as long as it doesn't need to enter config mode:

Websense_NCM_1.png

If I however tick the 'Execute Script in Config Mode', I get an error. 

Websense_NCM_2.png

Would you be able to advise further? Thank you.

0 Kudos
Level 7

I can get it to work by putting the password as part of the script, but that doesn't sound ideal and I'm concerned about the security of doing it that way.

Websense_NCM_3.png

0 Kudos

Hi, it’s been a while and I don’t remember if we exchanged the info what brand/model the device is? I would see if I can check with a similar device.

cheers

0 Kudos
Level 7

Hi Herr Doktor,

thank you for your reply. That's for a Forcepoint Web Security V5000 gateway. Cheers.


0 Kudos
Level 8

Hello!

I am having a similar issue, however my device is an APC UPS. I have the connection profile properly configured. I am looking to see about the commands used to actually back up the device (or is that even possible?) Please help if you can! 🙂

HerrDoktor

0 Kudos

From what I read in the APC CLi Reference, there is no backup Command, that shows the config line by line, so I am thinking that it is not possible to back up the config of this UPS.

0 Kudos
Level 8

HerrDoktor​ Ah okay, thank you, what about for Raritan devices? or A10 devices? any suggestions there?

0 Kudos

For NCM you need the possibility to log on to your device via SSH or Telnet and then there needs to be a command available that shows the config line by line. Check the CLI reference for each device if NCM doesn’t support it natively.

0 Kudos