cancel
Showing results for 
Search instead for 
Did you mean: 
Create Post
Level 7

Kiwi Syslog Server - Status Code 500

Hi community. I ve searched about my problem but only found topics related about Orin software. I am getting an exception in Kiwi Syslog Web Access. Status Code 500. Any one have experienced this issue ? Thanks a lot.

Exception of type 'System.Web.HttpUnhandledException' was thrown.

Status Code: 500


System.Web.HttpUnhandledException: Exception of type 'System.Web.HttpUnhandledException' was thrown. ---> System.ArgumentOutOfRangeException: 'capacity' must be non-negative.
Parameter name: capacity
at System.Collections.ArrayList..ctor(Int32 capacity)
at RadGridUserSettings.GetSerializedSettings()
at _Event.Render(HtmlTextWriter writer)
at System.Web.UI.Control.RenderControlInternal(HtmlTextWriter writer, ControlAdapter adapter)
at System.Web.UI.Control.RenderControl(HtmlTextWriter writer, ControlAdapter adapter)
at System.Web.UI.Control.RenderControl(HtmlTextWriter writer)
at Telerik.Web.UI.RadAjaxControl.RenderPageInAjaxMode(HtmlTextWriter writer, Control page)
at System.Web.UI.Control.RenderChildrenInternal(HtmlTextWriter writer, ICollection children)
at System.Web.UI.Control.RenderChildren(HtmlTextWriter writer)
at System.Web.UI.Page.Render(HtmlTextWriter writer)
at _Event.Render(HtmlTextWriter writer)
at System.Web.UI.Control.RenderControlInternal(HtmlTextWriter writer, ControlAdapter adapter)
at System.Web.UI.Control.RenderControl(HtmlTextWriter writer, ControlAdapter adapter)
at System.Web.UI.Control.RenderControl(HtmlTextWriter writer)
at Telerik.Web.UI.RadAjaxControl.RenderPageInAjaxMode(HtmlTextWriter writer, Control page)
at System.Web.UI.Control.RenderChildrenInternal(HtmlTextWriter writer, ICollection children)
at System.Web.UI.Control.RenderChildren(HtmlTextWriter writer)
at System.Web.UI.Page.Render(HtmlTextWriter writer)
at _Event.Render(HtmlTextWriter writer)
at System.Web.UI.Control.RenderControlInternal(HtmlTextWriter writer, ControlAdapter adapter)
at System.Web.UI.Control.RenderControl(HtmlTextWriter writer, ControlAdapter adapter)
at System.Web.UI.Control.RenderControl(HtmlTextWriter writer)
at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
--- End of inner exception stack trace ---
at System.Web.UI.Page.HandleError(Exception e)
at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
at System.Web.UI.Page.ProcessRequest(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
at System.Web.UI.Page.ProcessRequest()
at System.Web.UI.Page.ProcessRequestWithNoAssert(HttpContext context)
at System.Web.UI.Page.ProcessRequest(HttpContext context)
at ASP.events_aspx.ProcessRequest(HttpContext context)
at System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)

Resource: http://localhost:8088/Events.aspx
Referrer: http://localhost:8088/Gateway.aspx


Click here to return to the previous page    Click here to return to the login page

0 Kudos
11 Replies

Hi,

I tried accessing this link and it throws me a login page. Is that normal? Could you share the details here?

Cheers,

Abdhija

0 Kudos

Hi,

The solution for this error disappeared after the SolarWinds Success_Center URL changed in mid-April 2019.

The solution is described below, so please try it.

======================================

If Kiwi Web Access page is not displayed due to this Status Code: 500 error, it is solved by re-creating the DB file (Event.sdf).

A possible cause is that the temporary database used by Kiwi Web Access is corrupted.

The procedure is as follows.

* Please note that logs written in the past can not be viewed on WebAccess.

1. Stop the Kiwi Syslog Server service

2. Open the following folder

    C:¥Program Files(X86)¥Solarwinds¥Kiwi Syslog Web Access¥html¥App_Data¥

3. Move Event#.sdf file to another place

    (# Part is a number)

4. Copy the Event-blank.sdf file, rename it to "Event.sdf" and save it

5. Do not rename the original Event-blank.sdf file directly

6. Start the Kiwi Syslog Server Service

======================================

By re-creating the DB file (Event.sdf) in the above procedure,

Please check if Web Access will start.

0 Kudos
Level 15

Hey Stack,

I looked in the help file and are knowledge base and couldn't find anything. You can open a support ticket here. If I find anything in the meantime, I'll be sure to post it here.

0 Kudos

Thank you Bronx, but I think I cant do it. I am using the trial version. I do not have contract. 😞

0 Kudos

The Web Interface feature is only available in the licensed version, or for 30 days in the trial version, which you have. If you're beyond the 30 day trial version this feature will cease to work.

0 Kudos

Hi

I installed the software on Friday (24th) and it hasnt worked even the first time.

I am getting the same http errors.

It would be good if there is a way to log a call with the pre-sales team etc?

As its only a 30 day period, we need to assess the software before we plan to buy it (if)

Cheers

V

0 Kudos

VIJ,

Try the following and see if it helps:

1. Stop the Kiwi Syslog Server service.

2. Open the following directory:

-\Program Files\Solarwinds\Kiwi Syslog Web Access\html\App_Data\

3. Move Event#.sdf to an alternate location.

4. Copy Event-blank.sdf to Event.sdf

5. Start the Kiwi Syslog Server service.

Let me know.

Sincerely,

Chris Foley | Support Representative
SolarWinds | IT Management, Inspired By You
Support:866.530.8040 || Fax:512.857.0125

Chris' instructions above resolved my issue.  Thanks!

I had the same problem.

I followed Chris's instruction and it solved the problem.

Thank you.

0 Kudos

Hi Chris

When it was installed first, it was done as an application.So I re-installed it as a service and can get into the webpage now.

However, it says 'evaluation expired' at the top right hand side.

It was installed the 1st time on Friday and 2nd time today. So not sure why it says this.

I have sent some test messages and they get logged into the webpage.

I also configured one client and all those messages seem to go into 'kiwi syslog service manager' but not onto the web page

Cheers

V

0 Kudos