cancel
Showing results for 
Search instead for 
Did you mean: 
Create Post
Level 7

SSH protocol version 2 required by our configuration but server only provides SSH-1

I am attempting to run backups on a number of devices configured to use SSHv1. However, I get an error when I run the task. How can I resolve this? See attached for a screenshot.

0 Kudos
4 Replies
Level 7

Unfortunately I have come across some devices that don't support SSHv2 at all. Is there a setting somewhere to enable SSHv1 again?

0 Kudos

Please don't go there. There are excellent reasons to not use V1. Either upgrade the firmware on your devices or use this security best practice as a justification for replacing them.
0 Kudos

Your Solarwinds is correctly configured to only use SSH-v2 (congratulations!), but your devices are using V1 (boo, hiss!).

The right thing is to remote into each one and configure it for v2 only, deleting the v1 lines after proving v2 read-only or R/W access is successful.  This includes your security solution (ISE preferably, but Radius or other secure solution tying your credentials into your A.D. structure).  

The wrong thing to do is reconfigure your NCM to allow SSH-v1.  Don't do it.

 

Swift packets!

Rick Schroeder

0 Kudos

Cisco 3750's support SSHv2, it was supported by most, if not all, Cisco devices long before the 3750 even came out!   Rather than working on getting v1 to work, which is very insecure, why not move the 3750's over?   

You might have to generate a new crypto  key, and then do an "ip ssh version 2" and you should be set!