cancel
Showing results for 
Search instead for 
Did you mean: 
Create Post
Level 7

Aruba switch/router can't be queried

Hi everyone,

I try to setup some Kiwi tasks to simply query some commands on Aruba 2930F JL558A running WC.16.01.0008 and Aruba 8320 JL479A running TL.10.05.0001.

Debug logs - Aruba 2930F JL558A


<NEWSESSION CatTools 3.11.5 2020. 10. 08. 9:07:38>
<PROTOCOL=SSH2>
<DEVICE TYPE=Aruba.ArubaOS.General>
<ACTIVITY TYPE=Device.CLI.Send commands>
<ACTIVITY SCRIPT=C:\Program Files (x86)\CatTools3\Scripts\Client.Device.CLI.Send commands.txt>
<USERS NAME FOR DEVICE=HQusr-24>
<C OK 9:07:39>
<R-9:07:39>------------ W A R N I N G -------------[10] THIS SYSTEM IS RESTRICTED TO AUTHORIZED USERS FOR AUTHORIZED USE[10]ONLY. UNAUTHORIZED ACCESS IS STRICTLY PROHIBITED AND MAY BE[10]PUNISHABLE UNDER APPLICABLE LAWS. IF NOT AUTHORIZED TO ACCESS[10]THIS SYSTEM, DISCONNECT NOW. BY CONTINUING, YOU CONSENT TO YOUR[10]KEYSTROKES AND DATA CONTENT BEING MONITORED. ALL PERSONS ARE NOTIFIED[10]------------ W A R N I N G ------------- [10]
<R-9:07:39>
<R-9:07:40>Press any key to continue

The problem seems to be the prompt at the end but I tried all the option in the device setup (VTY, Enable etc. prompt) and neither helped.

 

Debug logs - Aruba 8320 JL479A


<NEWSESSION CatTools 3.11.5 2020. 10. 08. 9:19:21>
<PROTOCOL=SSH2>
<DEVICE TYPE=Aruba.ArubaOS.General>
<ACTIVITY TYPE=Device.CLI.Send commands>
<ACTIVITY SCRIPT=C:\Program Files (x86)\CatTools3\Scripts\Client.Device.CLI.Send commands.txt>
<USERS NAME FOR DEVICE=HQUSR-CORE-A>
<C OK 9:19:28>
<R-9:19:28>------------ FIGYELEM -------------[10]On a Budapest Bank vedett es monitorozott eszkozere jelentkezett be. [10]Amennyiben a munkakore kapcsan szukseges az eszkoz hasznalata, [10]kerjuk tegye ezt korultekintoen es a Budapest Bank ervenyes [10]szabalyzatait betartva! Ellenkezo esetben kerjuk jelentkezzen ki![10]------------ FIGYELEM ------------- [10]------------ FIGYELEM -------------[13][10]On a Budapest Bank vedett es monitorozott eszkozere jelentkezett be. [13][10]Amennyiben a munkakore kapcsan szukseges az eszkoz hasznalata, [13][10]kerjuk tegye ezt korultekintoen es a Budapest Bank ervenyes [13][10]szabalyzatait betartva! Ellenkezo esetben kerjuk jelentkezzen ki![13][10]------------ FIGYELEM ------------- [13][10]
<R-9:19:30>Last login: 2020-10-08 07:00:57 from 3.193.254.238[13][10]User "bankadmin" has logged in 61 times in the past 30 days[13][10]HQUSR-CORE-A#
<W-9:19:30>[13]
<R-9:19:30>[13][10]HQUSR-CORE-A#
<W-9:19:30>[13]
<R-9:19:30>[13][10]HQUSR-CORE-A#
<W-9:19:30>show interface lag brief
<R-9:19:30>show interface lag brief
<W-9:19:30>[13]
<R-9:19:30>[13][10]--------------------------------------------------------------------------------------------------------------[13][10]Port      Native  Mode   Type           Enabled Status  Reason                 Speed   Description[13][10]          VLAN                                                                 (Mb/s)  [13][10]--------------------------------------------------------------------------------------------------------------[13][10]lag100    1       trunk  --             yes     up      --                     1000    [13][10]lag150    1       trunk  --             yes     up      --                     10000   [13][10]lag151    1       trunk  --             yes     up      --                     10000   [13][10]lag152    1       trunk  --             yes     up      --                     10000   [13][10]lag153    1       trunk  --             yes     up      --                     10000   [13][10]lag154    1       trunk  --             yes     up      --                     10000   [13][10]lag155    1       trunk  --             yes     up      --                     10000   [13][10]lag156    1       trunk  --             yes     up      --                     10000   [13][10]lag157    1       trunk  --             yes     up      --                     10000   [13][10]lag158    1       trunk  --             yes     up      --                     10000   [13][10]lag159    1       trunk  --             yes     up      --                     10000   [13][10]lag160    1       trunk  --             yes     down    --                     auto    [13][10]lag161    1       trunk  --             yes     up      --                     10000   [13][10]lag162    1       trunk  --             yes     up      --                     10000   [13][10]lag163    1       trunk  --             yes     up      --                     10000   [13][10]lag164    1       trunk  --             yes     up      --                     10000   [13][10]lag255    1       access --             yes     down    --                     auto    [13][10]lag256    1       trunk  --             yes     up      --                     80000   [13][10]HQUSR-CORE-A#
<W-9:19:31>[13]
<R-9:19:31>[13][10]HQUSR-CORE-A#
<W-9:19:31>[13]
<R-9:19:31>[13][10]HQUSR-CORE-A#
<W-9:19:31>exit[13]
<W-9:19:31>[13]
<R-9:19:31>exit[13][10]
<D 9:19:31>
<SCRIPT VALUES>
<HOSTNAME="HQUSR-CORE-A">
<PROMPT VTY="HQUSR-CORE-A>">
<PROMPT ENABLE="HQUSR-CORE-A#">
<PROMPT CONFIG="HQUSR-CORE-A(config) #">


================================================================================
WFMDRetVal=1 Waiting for: "HQUSR-CORE-A>"
WFMDRetVal=2 Waiting for: "HQUSR-CORE-A#"
WFMDRetVal=3 Waiting for: "HQUSR-CORE-A(config) #"
WFMDRetVal=4 Waiting for: "(config)"
WFMDBuffer="exit[13][10]"
================================================================================

 

Here it seems that everything works correctly (no prompt) but at the end no e-mail is sent as specified in the activity's config.

In all the other tasks, e-mail sending works correctly.

 

Could you pelase help me?

 

Thank you in advance!

 

Andras

0 Kudos
0 Replies