cancel
Showing results for 
Search instead for 
Did you mean: 
Create Post
Level 13

Upgrading IPAM (and UDT) from Orion platform 2017.1.3 on Win 2012 R2 to 2020.2

Jump to solution

Question: Is the Upgrade Advisor "correct" that I can directly upgrade from IPAM 4.5.1 (Orion Platform 2017.1.3 SP3) to 2020.2 When my IPAM is on Windows 2012 R2?

Background on why I'm asking:

I have a few old, standalone Orion products that are still on Windows 2012 R2, using Orion Platform 2017.1.3 SP3.  I want to upgrade them to Orion 2020.2.  Per my understanding, SolarWinds has only recently begun supporting Windows 2012 R2 for upgrading to 2020.2 (it was not supported in the past, part of why we held up upgrades).  

There are some notes that upgrading *directly* to 2020.2 and still being on 2012 R2 is possible now.  However, there are some discrepancies on "how far back you can be and upgrade directly to 2020.2".  For example, the Install-OrionProducts indicates that you can use the installer to upgrade the platform from "2016.1 through 2018.4". BUT, my experience so far has got me wondering...

Running the "Upgrade Advisor" for UDT 3.2.4 (Orion Platform 2017.1.3 SP3) -> 2020.2  I get:

- Upgrade your operating system, choose one of these compatible systems: MS Windows Server 2019, MS Windows Server 2016, MS Windows 10

- Upgrade User Device Tracker from version 3.2.4 to version 3.4.0

- Upgrade User Device Tracker from version 3.4.0 to version 2020.2

Running the "Upgrade Advisor" for IPAM 4.5.1 (Orion Platform 2017.1.3 SP3) -> 2020.2 I get:

Upgrade IP Address Manager from version 4.5.1 to version 2020.2

 

So, with the same "base Orion platform" of Orion Platform 2017.1.3 SP3 , I get 2 recommendations on how to upgrade.  For IPAM it says "just run the installer" and for UDT it says "oh, upgrade Windows OS, then run a smaller install, oh by the way now an older OS is supposedly supported, too late for you to use the old OS! now you can go to 2020.2. which supports the old OS

So: I ran the installer on my UDT server to double check the "requirements" and it did a few odd things:

1. installed .NET 4.x, and some other install I didn't catch

2. Required me to reboot? (I rebooted)

3. *Then* allowed me to get far enough to run the "pre-upgrade checks".  And it said "sorry, Win2012 R2 is not supported!" I could not move forward with the install.

I was not expecting this, since Windows 2012 R2 should be a supported OS (even though the Upgrade Advisor did indicate this).  Maybe UDT is special and I'm *just on a barely too old version*.  Anyway, the reason I post this in the IPAM forum is because: My IPAM installation is more important than my UDT installation. I don't want to find out at the last minute during a change window I can't upgrade IPAM to 2020.2 directly, or I have to upgrade my OS to Windows 2016 *after* I may end up installing .NET and other things and rebooting just so I can run the pre-install checks. 

 

 

0 Kudos
1 Solution
MVP
MVP

The installer was most likely installing .NET 4.8 as that's what the newer versions use, and the reboot was to finish installing that.

UDT can't jump straight from 3.2.4 to 2020.2 without a step upgrade, and the step upgrade version it has chosen (3.4) doesn't support Windows 2012.

You could do a step-upgrade from UDT 3.2.4 to say 3.3.1, and then from there you can upgrade to 2020.2 (skipping over 3.4).

 

According to the upgrade path, you should be able to upgrade direct from IPAM 4.5.1 to 2020.2 so shouldn't run into the same issue with IPAM.

You can run the installer on your IPAM instance and run through the pre-upgrade checks without kicking off the IPAM upgrade (if you don't mind it installing/rebooting for .NET 4.8, or install .NET 4.8 as part of your Windows patching). That will give you a confirmation beforehand at least.

View solution in original post

0 Kudos
2 Replies
MVP
MVP

The installer was most likely installing .NET 4.8 as that's what the newer versions use, and the reboot was to finish installing that.

UDT can't jump straight from 3.2.4 to 2020.2 without a step upgrade, and the step upgrade version it has chosen (3.4) doesn't support Windows 2012.

You could do a step-upgrade from UDT 3.2.4 to say 3.3.1, and then from there you can upgrade to 2020.2 (skipping over 3.4).

 

According to the upgrade path, you should be able to upgrade direct from IPAM 4.5.1 to 2020.2 so shouldn't run into the same issue with IPAM.

You can run the installer on your IPAM instance and run through the pre-upgrade checks without kicking off the IPAM upgrade (if you don't mind it installing/rebooting for .NET 4.8, or install .NET 4.8 as part of your Windows patching). That will give you a confirmation beforehand at least.

View solution in original post

0 Kudos

Thanks for the info! 

I *definitely* want to try the "You could do a step-upgrade from UDT 3.2.4 to say 3.3.1, and then from there you can upgrade to 2020.2 (skipping over 3.4)" as I'd love to stay on Win 2012 for the rest of the year. I'm planning on doing Win OS 2012 -> 2016/2019 updates later (if I can wait just a little bit longer I can skip Win 2016 and go to Win OS 2019, which we don't support in house just yet.  Win 2019 is still in the "testing" phase so I can't put a production app on it yet.).

The .NET install + reboot appears to be something I'm not going to be able to work around, so I'll plan it as a "pre upgrade tasks" change control for it, as part of a SQL DB migration (There's a push to get my SQL DB's moved over to SQL 2016, and I'd have to wait a bit for the next OS patch cycle if I did .NET then).

0 Kudos