cancel
Showing results for 
Search instead for 
Did you mean: 
Create Post

Solarwinds VIP issue during HA Failover

Jump to solution

When
SolarWinds application fail over is happening from primary to secondary, VIP is
getting removed from primary server and not getting assigned to the secondary
server network adapter. Because of which HA pool is getting fluctuated from
secondary to primary and vice versa. During fail over time SolarWinds web
console is not reachable with Virtual ip.

0 Kudos
1 Solution

Post Enabling of DHCP service on all Solarwinds server VIP started getting assigned and Web-console related issue post fail over got resolved by doing minor changes in IIS pool setting from Running on demand to always running.

Will suggest that Enabling of DCHP service should be there in prerequisite document of Solarwinds.

View solution in original post

16 Replies
Level 8

Yes!!!

Finally we get the resolution after struggling for 6 months on this case,Onley we have enable the DHCP services on all of the server.

Congrats team....

Lets cheer..

Post Enabling of DHCP service on all Solarwinds server VIP started getting assigned and Web-console related issue post fail over got resolved by doing minor changes in IIS pool setting from Running on demand to always running.

Will suggest that Enabling of DCHP service should be there in prerequisite document of Solarwinds.

View solution in original post

abhishekthakur  wrote:

Post Enabling of DHCP service on all Solarwinds server VIP started getting assigned and Web-console related issue post fail over got resolved by doing minor changes in IIS pool setting from Running on demand to always running.

Will suggest that Enabling of DCHP service should be there in prerequisite document of Solarwinds.

By 'DHCP service' can I assume you are refering to the 'DHCP Client' service?

Yes,its DHCP Client Service

Thank you for confirming. I've captured this information internally under case INFODEV-2472

Level 8

Hi everyone

After enabling the DHCP services on all of the server including Main polling engine and additional polling engine,the VIP is assigning automatically on secondary server. Previously after the fail over we need to put the VIP manually on secondary server.

Here we have encountered new issue ,the web-console is accessible properly when there is fail-over happens on additional polling engine,but when there is fail-over happens,VIP is assigning properly on secondary server ,but we are not able to access the secondary server through VIP or physical IP of secondary server.Can any one have any suggestion for that one?? How can we troubleshoot it.

0 Kudos

If you do an 'ipconfig /all' on that sever does it show the VIP assigned? Are any interfaces on that server assigned via DHCP?

0 Kudos
Level 8

Hi Everyone

Is there any other way to investigate this issue. If there is any possibility please help me out. We have already raised the case with support.The case id is 003479004.

Thanks in advance for any suggestion.

0 Kudos
Product Manager
Product Manager

Without looking through your log files, it's difficult to say what the cause of the issue might be. I would suggest breaking the pool and recreating it (should only take a minute or two with no disruption of service) and see if that resolves the issue. If it does not, please open a case with support so we can determine the cause of the issue.

0 Kudos

we have tried all the things but issue is not getting resolved.Solarwinds support is telling it is not a issue with application

Are there any errors in the Windows Event Log when the failover occurs? What happens when you attempt to assign a secondary IP address to the server? Is there anything unusual about the secondary machine, such as NIC teaming, differing subnet masks, or 3rd party NIC software? I'm really reaching here, but without some additional information to go on, I'm afraid my helpfulness will probably be limited. If you can provide your case number, I'm happy to review it and see it should be escalated.

0 Kudos

Fail over from primary to secondary is happening properly but as VIP is getting removed from secondary NIC adapter hence console is inaccessible through VIP.   Secondary IP is getting attached manually without any issue.

Case ID for same: 00347904

0 Kudos

So just to confirm, after failing over to the secondary server, if you perform an 'ipconfig' the VIP does not appear listed?

Screen Shot 2019-11-14 at 8.16.06 PM.png

0 Kudos

Yes,after fail-over VIP doesn't comes after running ipconfig Command.We need to add the VIP manually in NIC for gettiing the VIP.

Are there any errors in the Windows Event Log when the failover occurs?

0 Kudos

We cannot see any error related to fail over in windows logs during failover .

As we have one main polling engine and two APE and i am facing same issue for ape and main polling engine.