Showing results for 
Search instead for 
Did you mean: 
Create Post
Level 8

RabbitMQ error while installing SolarWinds HA

Hi All,

I have installed SAM production version in my environment successfully.

When trying to install SolarWinds HA for the same I'm getting RabbitMQ service error.


I downloaded the setup from Customer portal.

The main server and HA are in different subnets with required ports opened bidirectional.

Firewall and Antivirus is disabled and user is local admin, with no hardening done on server.

Tried repairing and reinstalling service as well.

Tried running Configuration Wizard through cmd.

Also tried installing on a fresh server with the same .exe file but same error.

Tried all the steps mentioned in article - Success Center

Also, I'm able to see RabbitMQ service.

We tried doing forced failover and it worked but still the error persists.

Kindly help.


Rucha Vaidya


0 Kudos
6 Replies
Product Manager
Product Manager

0 Kudos

FYR Case # - 00363707

0 Kudos

I would recommend trying the steps listed below

1. Uninstall "RabbitMQ Server (SolarWinds Distribution)" from Programs and Features

2. Delete C:\ProgramData\Solarwinds\Orion\RabbitMQ

3. Please check if all files are deleted from the folder!

4. Delete the service control entry with sc delete rabbitmq

5. Delete HKEY_LOCAL_MACHINE\SOFTWARE\Ericsson from the registry.

6. Delete C:\Program Files (x86)\SolarWinds\RabbitMQ folder (may require a restart)

7. Install C:\ProgramData\Solarwinds\Installers\SolarWinds.RabbitMQ.Install.msi.

8. Execute c:\Program Files (x86)\SolarWinds\Orion\RabbitMQ\sbin\rabbitmq-service.bat install

9. Run the Database and Services section of the Configuration Wizard.

The most important thing here is to check that after step 2 the RabbitMQ folder is deleted.

In some cases, there is a problem with privileges to delete this folder.

If it is a failure, then I would recommend for you to skip 1-6 and just go directly through 7-9.  I would not expect to have the folders and registry keys if it is a new installation.

also, make sure you have the pubsubovermessage enabled.

HA host going into down(red)state

0 Kudos


Yes I had opened a case with support.

They had earlier suggested to run Config Wizard through cmd but it didnt help.

Also we donot have internet access in our environment so webex is not possible for troubleshooting.

0 Kudos